Every CVE Search/ Get API key

CVE-2006-5876

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows...

7.8 HighFix available

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows remote attackers to cause a denial of service (crash) via malformed HTTP headers, probably involving missing fields or values.

Exploit likelihood

2.76%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows remote attackers to cause a denial of service (crash) via malformed HTTP headers, probably involving missing fields or values.

Record
CVE-2006-5876
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Updated
2026-11-02
CVE List No score

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows remote attackers to cause a denial of service (crash) via malformed HTTP headers, probably involving missing fields or values.

Record
CVE-2006-5876
Updated
2026-11-02
EUVDEUVD-2006-5860 No score

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows remote attackers to cause a denial of service (crash) via malformed HTTP headers, probably involving missing fields or values.

Record
EUVD-2006-5860
Updated
2026-11-03
GitHub AdvisoriesGHSA-497p-q4hc-83hp No score

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows...

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows remote attackers to cause a denial of service (crash) via malformed HTTP headers, probably involving missing fields or values.

Record
GHSA-497p-q4hc-83hp
Updated
2026-11-02
OSVDEBIAN-CVE-2006-5876 No score

The soup_headers_parse function in soup-headers.c for libsoup HTTP library before 2.2.99 allows remote attackers to cause a denial of service (crash) via malformed HTTP headers, probably involving missing fields or values.

Record
DEBIAN-CVE-2006-5876
Updated
2026-11-02
OSVopenSUSE-SU-2024:10994-1 No score

libsoup-2_4-1-2.72.0-2.5 on GA media

These are all security issues fixed in the libsoup-2_4-1-2.72.0-2.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10994-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsoup
Debian:14
before 2.2.98-2, plus listed versions
2.1.2-12.1.5-12.1.7-12.2.2-12.2.3-1
Show 15 moreShow less
2.2.3-22.2.3-2sarge12.2.6-12.2.7-12.2.7-22.2.91-12.2.91-22.2.92-12.2.93-12.2.93-22.2.93-32.2.95.1-12.2.96-12.2.97-12.2.98-1
2.2.98-2
libsoup
Debian:3.1
before 2.2.3-2sarge1, plus listed versions
2.2.3-2
2.2.3-2sarge1
libsoup
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 2.72.0-2.5
2.72.0-2.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-5876 is a high vulnerability (CVSS 7.8) in Libsoup, published January 12, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.76%, the 86th percentile. Fixed in libsoup 2.2.98-2.

References

Show 16 moreShow less
MoveEnter Open