CVE-2006-6661
Variable overwrite vulnerability in blog.php in PHP-Update 2.7 and earlier allows remote...
Variable overwrite vulnerability in blog.php in PHP-Update 2.7 and earlier allows remote attackers to overwrite arbitrary program variables and execute arbitrary PHP code via multiple vectors that use the extract function, as demonstrated by the (1) f, (2) newmessage, (3) newusername, (4) adminuser, and (5) permission parameters.
Exploit likelihood
What each source reports
NVD Score used
7.5
Variable overwrite vulnerability in blog.php in PHP-Update 2.7 and earlier allows remote attackers to overwrite arbitrary program variables and execute arbitrary PHP code via multiple vectors that use the extract function, as demonstrated by the (1) f, (2) newmessage, (3) newusername, (4) adminuser, and (5) permission parameters.
- Record
CVE-2006-6661- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Variable overwrite vulnerability in blog.php in PHP-Update 2.7 and earlier allows remote attackers to overwrite arbitrary program variables and execute arbitrary PHP code via multiple vectors that use the extract function, as demonstrated by the (1) f, (2) newmessage, (3) newusername, (4) adminuser, and (5) permission parameters.
- Record
CVE-2006-6661- Updated
- 2026-11-02
EUVDEUVD-2006-6644 No score
Variable overwrite vulnerability in blog.php in PHP-Update 2.7 and earlier allows remote attackers to overwrite arbitrary program variables and execute arbitrary PHP code via multiple vectors that use the extract function, as demonstrated by the (1) f, (2) newmessage, (3) newusername, (4) adminuser, and (5) permission parameters.
- Record
EUVD-2006-6644- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qhrq-r9hf-mvc8 No score
Variable overwrite vulnerability in blog.php in PHP-Update 2.7 and earlier allows remote...
Variable overwrite vulnerability in blog.php in PHP-Update 2.7 and earlier allows remote attackers to overwrite arbitrary program variables and execute arbitrary PHP code via multiple vectors that use the extract function, as demonstrated by the (1) f, (2) newmessage, (3) newusername, (4) adminuser, and (5) permission parameters.
- Record
GHSA-qhrq-r9hf-mvc8- Updated
- 2026-11-02
Affected products
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | PHP-Update 2.7 - 'extract()' Authentication Bypass / Shell Injection | 2006-12-19 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-6661 is a high vulnerability (CVSS 7.5) in Php-update, published December 20, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 6.65%, the 93rd percentile. No source names a fixed version.