CVE-2006-7162
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys...
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.
Exploit likelihood
What each source reports
NVD Score used
1.9
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.
- Record
CVE-2006-7162- CVSS 2.0
- 1.9 Low
AV:L/AC:M/Au:N/C:P/I:N/A:N - Updated
- 2026-11-02
CVE List No score
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.
- Record
CVE-2006-7162- Updated
- 2026-11-02
EUVDEUVD-2006-7144 No score
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.
- Record
EUVD-2006-7144- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-72fv-g98m-465j No score
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys...
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.
- Record
GHSA-72fv-g98m-465j- Updated
- 2026-11-02
OSV No score
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.
- Record
CVE-2006-7162- Updated
- 2026-11-02
OSVDEBIAN-CVE-2006-7162 No score
PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.
- Record
DEBIAN-CVE-2006-7162- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-7162 is a low vulnerability (CVSS 1.9) in Putty, published March 7, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.31%, the 24th percentile. Fixed in putty 0.59-1.