Every CVE Search/ Get API key

CVE-2006-7216

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements...

4.0 MediumFix available

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements at compilation time, and consequently does not enforce privilege requirements at execution time, which allows remote authenticated users to lock arbitrary tables.

Exploit likelihood

2.17%Down 2.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements at compilation time, and consequently does not enforce privilege requirements at execution time, which allows remote authenticated users to lock arbitrary tables.

Record
CVE-2006-7216
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements at compilation time, and consequently does not enforce privilege requirements at execution time, which allows remote authenticated users to lock arbitrary tables.

Record
CVE-2006-7216
Updated
2026-11-02
EUVDEUVD-2006-7195 No score

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements at compilation time, and consequently does not enforce privilege requirements at execution time, which allows remote authenticated users to lock arbitrary tables.

Record
EUVD-2006-7195
Updated
2026-11-03
GitHub AdvisoriesGHSA-3ph6-4gjf-m5qj No score

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements...

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements at compilation time, and consequently does not enforce privilege requirements at execution time, which allows remote authenticated users to lock arbitrary tables.

Record
GHSA-3ph6-4gjf-m5qj
Updated
2026-11-02
OSVopenSUSE-SU-2024:10092-1 No score

derby-10.11.1.1-3.2 on GA media

These are all security issues fixed in the derby-10.11.1.1-3.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10092-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
derby
openSUSE:Tumbleweed
before 10.11.1.1-3.2
10.11.1.1-3.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-7216 is a medium vulnerability (CVSS 4.0) in Apache Derby, published July 5, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.17%, the 82nd percentile. Fixed in derby 10.11.1.1-3.2.

References

MoveEnter Open