Every CVE Search/ Get API key

CVE-2006-7230

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the...

4.3 MediumFix available

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

Exploit likelihood

1.67%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

Record
CVE-2006-7230
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

Record
CVE-2006-7230
Updated
2026-11-02
EUVDEUVD-2006-7207 No score

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

Record
EUVD-2006-7207
Updated
2026-11-03
GitHub AdvisoriesGHSA-64q5-vm73-jhjp No score

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the...

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

Record
GHSA-64q5-vm73-jhjp
Updated
2026-11-02
OSV No score

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

Record
CVE-2006-7230
Updated
2026-11-02
OSVDEBIAN-CVE-2006-7230 No score

Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

Record
DEBIAN-CVE-2006-7230
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pcre3
Debian:12
before 7.0-1
7.0-1
kazehakase
Debian:4.0
From an advisory covering 10 CVEs
before 0.4.2-1etch1, plus listed versions
0.4.2-1
0.4.2-1etch1
pcre
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-debuginfo
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-devel
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre
Red Hat:enterprise_linux:5::client
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-debuginfo
Red Hat:enterprise_linux:5::client
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre
Red Hat:enterprise_linux:5::server
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-debuginfo
Red Hat:enterprise_linux:5::server
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-devel
Red Hat:enterprise_linux:5::server
From an advisory covering 4 CVEs
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
Show 12 moreShow less
Affected packages
PackageAffectedFixed
pcre
Red Hat:enterprise_linux:4::as
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::as
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::desktop
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::desktop
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::desktop
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::es
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::es
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::ws
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::ws
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::ws
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-7230 is a medium vulnerability (CVSS 4.3) in Pcre, published November 15, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.67%, the 76th percentile. Fixed in pcre3 7.0-1.

References

Show 48 moreShow less
MoveEnter Open