CVE-2007-0104
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before...
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
Exploit likelihood
What each source reports
NVD Score used
6.8
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
- Record
CVE-2007-0104- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
- Record
CVE-2007-0104- Updated
- 2026-11-02
EUVDEUVD-2007-0108 No score
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
- Record
EUVD-2007-0108- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8w95-hg52-rgm5 No score
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before...
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
- Record
GHSA-8w95-hg52-rgm5- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
- Record
CVE-2007-0104- Updated
- 2026-11-02
OSVDEBIAN-CVE-2007-0104 No score
The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.
- Record
DEBIAN-CVE-2007-0104- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10707-1 No score
cups-2.3.3op2-4.2 on GA media
These are all security issues fixed in the cups-2.3.3op2-4.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10707-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11181-1 No score
libpoppler-cpp0-21.08.0-1.3 on GA media
These are all security issues fixed in the libpoppler-cpp0-21.08.0-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11181-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
popplerDebian:12 |
before 0.4.5-5.1 | 0.4.5-5.1 |
popplerDebian:13 |
before 0.4.5-5.1 | 0.4.5-5.1 |
popplerDebian:14 |
before 0.4.5-5.1 | 0.4.5-5.1 |
xpdfDebian:12 |
before 3.02 | 3.02 |
xpdfDebian:13 |
before 3.02 | 3.02 |
xpdfDebian:14 |
before 3.02 | 3.02 |
cupsopenSUSE:Tumbleweed From an advisory covering 20 CVEs |
before 2.3.3op2-4.2 | 2.3.3op2-4.2 |
poppleropenSUSE:Tumbleweed From an advisory covering 9 CVEs |
before 21.08.0-1.3 | 21.08.0-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2007-0104 is a medium vulnerability (CVSS 6.8) in Kde, published January 9, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.23%, the 93rd percentile. Fixed in poppler 0.4.5-5.1.
References
secunia.com/advisories/23815
mandriva.com/security/advisories?name=MDKSA-2007:022
mandriva.com/security/advisories?name=MDKSA-2007:020
us-cert.gov/cas/techalerts/TA07-072A.html
mandriva.com/security/advisories?name=MDKSA-2007:021
kde.org/info/security/advisory-20070115-1.txt
Show 57 moreShow less
mandriva.com/security/advisories?name=MDKSA-2007:019
secunia.com/advisories/23799
secunia.com/advisories/23839
docs.info.apple.com/article.html?artnum=305214
exchange.xforce.ibmcloud.com/vulnerabilities/31364
ubuntu.com/usn/usn-410-2
mandriva.com/security/advisories?name=MDKSA-2007:018
securitytracker.com/id?1017514
secunia.com/advisories/23791
novell.com/linux/security/advisories/2007_3_sr.html
support.novell.com/techcenter/psdb/44d7cb9b669d58e0ce5aa5d7ab2c7c53.html
securityfocus.com/bid/21910
mandriva.com/security/advisories?name=MDKSA-2007:024
securitytracker.com/id?1017749
projects.info-pull.com/moab/MOAB-06-01-2007.html
secunia.com/advisories/23844
ubuntu.com/usn/usn-410-1
vupen.com/english/advisories/2007/0203
secunia.com/advisories/23876
securityfocus.com/archive/1/457055/100/0/threaded
vupen.com/english/advisories/2007/0244
vupen.com/english/advisories/2007/0212
vupen.com/english/advisories/2007/0930
issues.rpath.com/browse/RPL-964
secunia.com/advisories/23813
secunia.com/advisories/24204
secunia.com/advisories/23808
secunia.com/advisories/24479
nvd.nist.gov/vuln/detail/CVE-2007-0104
github.com/advisories/GHSA-8w95-hg52-rgm5
security-tracker.debian.org/tracker/CVE-2007-0104
suse.com/security/cve/CVE-2005-3193
suse.com/security/cve/CVE-2005-3624
suse.com/security/cve/CVE-2005-3628
suse.com/security/cve/CVE-2007-0104
suse.com/security/cve/CVE-2007-3387
suse.com/security/cve/CVE-2007-4351
suse.com/security/cve/CVE-2007-4352
suse.com/security/cve/CVE-2007-5393
suse.com/security/cve/CVE-2008-0047
suse.com/security/cve/CVE-2008-1693
suse.com/security/cve/CVE-2008-1722
suse.com/security/cve/CVE-2008-3641
suse.com/security/cve/CVE-2017-18248
suse.com/security/cve/CVE-2018-4700
suse.com/security/cve/CVE-2019-2228
suse.com/security/cve/CVE-2019-8696
suse.com/security/cve/CVE-2019-8842
suse.com/security/cve/CVE-2020-10001
suse.com/security/cve/CVE-2020-3898
suse.com/security/cve/CVE-2021-25317
suse.com/security/cve/CVE-2006-0301
suse.com/security/cve/CVE-2007-5392
suse.com/security/cve/CVE-2008-2950
suse.com/security/cve/CVE-2017-14517
suse.com/security/cve/CVE-2017-14518
suse.com/security/cve/CVE-2017-7515