Every CVE Search/ Get API key

CVE-2007-0469

RubyGems file overwrite vulnerability

9.3 HighFix available

CVE-2007-0469 is a high vulnerability (CVSS 9.3) in Rubyforge Rubygems, published January 24, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.86%, the 92nd percentile. Fixed in rubygems-update 0.9.1.

The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.

Exploit likelihood

4.86%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.

Record
CVE-2007-0469
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.

Record
CVE-2007-0469
Updated
2026-11-02
EUVDEUVD-2022-3295 No score

The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.

Record
EUVD-2022-3295
Updated
2026-11-03
GitHub AdvisoriesGHSA-95vx-q4c2-64gr No score

RubyGems file overwrite vulnerability

The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.

Record
GHSA-95vx-q4c2-64gr
Updated
2026-11-02
OSVGHSA-95vx-q4c2-64gr No score

RubyGems file overwrite vulnerability

The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.

Record
GHSA-95vx-q4c2-64gr
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rubygems-update
RubyGems
before 0.9.1
0.9.1
rubygems-update
RubyGems
before 0.9.1, plus listed versions
0.8.100.8.110.8.30.8.40.8.50.8.60.8.80.9.0
0.9.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open