Every CVE Search/ Get API key

CVE-2007-1659

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers...

6.8 MediumFix available

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via regex patterns containing unmatched "\Q\E" sequences with orphan "\E" codes.

Exploit likelihood

3.53%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via regex patterns containing unmatched "\Q\E" sequences with orphan "\E" codes.

Record
CVE-2007-1659
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via regex patterns containing unmatched "\Q\E" sequences with orphan "\E" codes.

Record
CVE-2007-1659
Updated
2026-11-02
EUVDEUVD-2007-1653 No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via regex patterns containing unmatched "\Q\E" sequences with orphan "\E" codes.

Record
EUVD-2007-1653
Updated
2026-11-03
GitHub AdvisoriesGHSA-h2p6-9f3w-vqw9 No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers...

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via regex patterns containing unmatched "\Q\E" sequences with orphan "\E" codes.

Record
GHSA-h2p6-9f3w-vqw9
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via regex patterns containing unmatched "\Q\E" sequences with orphan "\E" codes.

Record
CVE-2007-1659
Updated
2026-11-02
OSVDEBIAN-CVE-2007-1659 No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via regex patterns containing unmatched "\Q\E" sequences with orphan "\E" codes.

Record
DEBIAN-CVE-2007-1659
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glib2.0
Debian:12
before 2.14.3-1
2.14.3-1
glib2.0
Debian:13
before 2.14.3-1
2.14.3-1
glib2.0
Debian:14
before 2.14.3-1
2.14.3-1
pcre3
Debian:12
before 7.3-1
7.3-1
pcre3
Debian:3.1
From an advisory covering 7 CVEs
before 4.5+7.4-1, plus listed versions
4.5-1.24.5-1.2sarge1
4.5+7.4-1
pcre3
Debian:4.0
From an advisory covering 7 CVEs
before 6.7+7.4-2, plus listed versions
6.7+7.4-16.7-1
6.7+7.4-2
kazehakase
Debian:4.0
From an advisory covering 10 CVEs
before 0.4.2-1etch1, plus listed versions
0.4.2-1
0.4.2-1etch1
pcre3
Debian:5.0
From an advisory covering 7 CVEs
before 6.7+7.4-2+lenny1
6.7+7.4-2+lenny1
pcre
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
pcre-debuginfo
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
Show 18 moreShow less
Affected packages
PackageAffectedFixed
pcre-devel
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
pcre
Red Hat:enterprise_linux:5::client
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
pcre-debuginfo
Red Hat:enterprise_linux:5::client
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
pcre
Red Hat:enterprise_linux:5::server
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
pcre-debuginfo
Red Hat:enterprise_linux:5::server
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
pcre-devel
Red Hat:enterprise_linux:5::server
From an advisory covering 2 CVEs
before 0:6.6-2.el5_0.1
0:6.6-2.el5_0.1
pcre
Red Hat:enterprise_linux:4::as
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::as
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::as
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::desktop
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::desktop
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::desktop
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::es
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::es
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::es
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::ws
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::ws
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::ws
From an advisory covering 5 CVEs
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-1659 is a medium vulnerability (CVSS 6.8) in Pcre, published November 5, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.53%, the 89th percentile. Fixed in glib2.0 2.14.3-1.

References

Show 83 moreShow less
MoveEnter Open