Every CVE Search/ Get API key

CVE-2007-1661

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching...

6.4 MediumFix available

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

Exploit likelihood

2.49%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

Record
CVE-2007-1661
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:N/A:P
Updated
2026-11-02
CVE List No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

Record
CVE-2007-1661
Updated
2026-11-02
EUVDEUVD-2007-1655 No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

Record
EUVD-2007-1655
Updated
2026-11-03
GitHub AdvisoriesGHSA-759q-4q8w-5gfh No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching...

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

Record
GHSA-759q-4q8w-5gfh
Updated
2026-11-02
OSV No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

Record
CVE-2007-1661
Updated
2026-11-02
OSVDEBIAN-CVE-2007-1661 No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

Record
DEBIAN-CVE-2007-1661
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glib2.0
Debian:12
before 2.14.3-1
2.14.3-1
glib2.0
Debian:13
before 2.14.3-1
2.14.3-1
glib2.0
Debian:14
before 2.14.3-1
2.14.3-1
pcre3
Debian:12
before 7.3-1
7.3-1
pcre3
Debian:3.1
From an advisory covering 7 CVEs
before 4.5+7.4-1, plus listed versions
4.5-1.24.5-1.2sarge1
4.5+7.4-1
pcre3
Debian:4.0
From an advisory covering 7 CVEs
before 6.7+7.4-2, plus listed versions
6.7+7.4-16.7-1
6.7+7.4-2
kazehakase
Debian:4.0
From an advisory covering 10 CVEs
before 0.4.2-1etch1, plus listed versions
0.4.2-1
0.4.2-1etch1
pcre3
Debian:5.0
From an advisory covering 7 CVEs
before 6.7+7.4-2+lenny1
6.7+7.4-2+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-1661 is a medium vulnerability (CVSS 6.4) in Apple Mac Os X, published November 5, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.49%, the 84th percentile. Fixed in glib2.0 2.14.3-1.

References

Show 41 moreShow less
MoveEnter Open