Every CVE Search/ Get API key

CVE-2007-1777

Integer overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to...

7.5 HighPublic exploitFix available

CVE-2007-1777 is a high vulnerability (CVSS 7.5) in Php, published March 30, 2007. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 15.5%, the 96th percentile. Fixed in php4 4:4.3.10-20.

Integer overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to execute arbitrary code via a ZIP archive that contains an entry with a length value of 0xffffffff, which is incremented before use in an emalloc call, triggering a heap overflow.

Exploit likelihood

15.5%Down 4.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Integer overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to execute arbitrary code via a ZIP archive that contains an entry with a length value of 0xffffffff, which is incremented before use in an emalloc call, triggering a heap overflow.

Record
CVE-2007-1777
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Integer overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to execute arbitrary code via a ZIP archive that contains an entry with a length value of 0xffffffff, which is incremented before use in an emalloc call, triggering a heap overflow.

Record
CVE-2007-1777
Updated
2026-11-02
EUVDEUVD-2007-1771 No score

Integer overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to execute arbitrary code via a ZIP archive that contains an entry with a length value of 0xffffffff, which is incremented before use in an emalloc call, triggering a heap overflow.

Record
EUVD-2007-1771
Updated
2026-11-03
GitHub AdvisoriesGHSA-grwx-x87w-vjjp No score

Integer overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to...

Integer overflow in the zip_read_entry function in PHP 4 before 4.4.5 allows remote attackers to execute arbitrary code via a ZIP archive that contains an entry with a length value of 0xffffffff, which is incremented before use in an emalloc call, triggering a heap overflow.

Record
GHSA-grwx-x87w-vjjp
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php4
Debian:3.1
before 4:4.3.10-20, plus listed versions
4:4.3.10-154:4.3.10-164:4.3.10-174:4.3.10-184:4.3.10-19
4:4.3.10-20
php4
Debian:4.0
before 6:4.4.4-8+etch2, plus listed versions
6:4.4.4-8+etch1
6:4.4.4-8+etch2
php5
Debian:4.0
before 5.2.0-8+etch3, plus listed versions
5.2.0-8+etch1
5.2.0-8+etch3
php5
Debian:5.0
before 5.2.0-10+lenny1
5.2.0-10+lenny1
php4
Debian:5.0
before 6:4.4.4-9+lenny1, plus listed versions
4.0.3pl1-0potato34.0.3pl1-0potato44:4.1.2-74:4.1.2-7.0.14:4.1.2-7.woody3
Show 41 moreShow less
4:4.1.2-7.woody44:4.1.2-7.woody54:4.1.2-7woody14:4.1.2-7woody24:4.3.10-104:4.3.10-114:4.3.10-124:4.3.10-134:4.3.10-144:4.3.10-154:4.3.10-164:4.3.10-174:4.3.10-184:4.3.10-194:4.3.10-204:4.3.10-214:4.3.10-224:4.3.10-84:4.3.10-94:4.4.0-14:4.4.0-24:4.4.0-34:4.4.0-44:4.4.2-14:4.4.2-1+b14:4.4.2-1.14:4.4.4-14:4.4.4-24:4.4.4-34:4.4.4-44:4.4.4-4~44:4.4.4-54:4.4.4-64:4.4.4-76:4.4.4-86:4.4.4-8+etch16:4.4.4-8+etch26:4.4.4-8+etch36:4.4.4-8+etch46:4.4.4-8+etch66:4.4.4-9
6:4.4.4-9+lenny1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBPHP 4.4.4 - 'Zip_Entry_Read()' Integer Overflow2007-03-27

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02aliases
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 4 moreShow less
MoveEnter Open