CVE-2007-2165
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are...
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are configured, does not require that the module that checks authentication is the same as the module that retrieves authentication data, which might allow remote attackers to bypass authentication, as demonstrated by use of SQLAuthTypes Plaintext in mod_sql, with data retrieved from /etc/passwd.
Exploit likelihood
What each source reports
NVD Score used
5.1
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are configured, does not require that the module that checks authentication is the same as the module that retrieves authentication data, which might allow remote attackers to bypass authentication, as demonstrated by use of SQLAuthTypes Plaintext in mod_sql, with data retrieved from /etc/passwd.
- Record
CVE-2007-2165- CVSS 2.0
- 5.1 Medium
AV:N/AC:H/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are configured, does not require that the module that checks authentication is the same as the module that retrieves authentication data, which might allow remote attackers to bypass authentication, as demonstrated by use of SQLAuthTypes Plaintext in mod_sql, with data retrieved from /etc/passwd.
- Record
CVE-2007-2165- Updated
- 2026-11-02
EUVDEUVD-2007-2160 No score
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are configured, does not require that the module that checks authentication is the same as the module that retrieves authentication data, which might allow remote attackers to bypass authentication, as demonstrated by use of SQLAuthTypes Plaintext in mod_sql, with data retrieved from /etc/passwd.
- Record
EUVD-2007-2160- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5xmx-5p6r-vfrv No score
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are...
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are configured, does not require that the module that checks authentication is the same as the module that retrieves authentication data, which might allow remote attackers to bypass authentication, as demonstrated by use of SQLAuthTypes Plaintext in mod_sql, with data retrieved from /etc/passwd.
- Record
GHSA-5xmx-5p6r-vfrv- Updated
- 2026-11-02
OSV No score
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are configured, does not require that the module that checks authentication is the same as the module that retrieves authentication data, which might allow remote attackers to bypass authentication, as demonstrated by use of SQLAuthTypes Plaintext in mod_sql, with data retrieved from /etc/passwd.
- Record
CVE-2007-2165- Updated
- 2026-11-02
OSVDEBIAN-CVE-2007-2165 No score
The Auth API in ProFTPD before 20070417, when multiple simultaneous authentication modules are configured, does not require that the module that checks authentication is the same as the module that retrieves authentication data, which might allow remote attackers to bypass authentication, as demonstrated by use of SQLAuthTypes Plaintext in mod_sql, with data retrieved from /etc/passwd.
- Record
DEBIAN-CVE-2007-2165- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
proftpd-dfsgDebian:12 |
before 1.3.0-24 | 1.3.0-24 |
proftpd-dfsgDebian:13 |
before 1.3.0-24 | 1.3.0-24 |
proftpd-dfsgDebian:14 |
before 1.3.0-24 | 1.3.0-24 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| affected, aliases, facts, references, title | GitHub Advisories, OSV | |
| first indexed | CVE List, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2007-2165 is a medium vulnerability (CVSS 5.1) in Proftpd Project Proftpd, published April 22, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 12.2%, the 96th percentile. Fixed in proftpd-dfsg 1.3.0-24.
References
bugs.debian.org/cgi-bin/bugreport.cgi?bug=419255
bugs.proftpd.org/show_bug.cgi?id=2922
bugzilla.redhat.com/show_bug.cgi?id=237533
mandriva.com/security/advisories?name=MDKSA-2007:130
secunia.com/advisories/25724
securityfocus.com/bid/23546
Show 10 moreShow less
secunia.com/advisories/24867
osvdb.org/34602
vupen.com/english/advisories/2007/1444
securitytracker.com/id?1017931
redhat.com/archives/fedora-package-announce/2007-November/msg00065.html
secunia.com/advisories/27516
exchange.xforce.ibmcloud.com/vulnerabilities/33733
nvd.nist.gov/vuln/detail/CVE-2007-2165
github.com/advisories/GHSA-5xmx-5p6r-vfrv
security-tracker.debian.org/tracker/CVE-2007-2165