Every CVE Search/ Get API key

CVE-2007-2589

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4...

5.0 MediumFix available

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4.9a allows remote attackers to send e-mails from arbitrary users via certain data in the SRC attribute of an IMG element.

Exploit likelihood

1.37%Down 2.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4.9a allows remote attackers to send e-mails from arbitrary users via certain data in the SRC attribute of an IMG element.

Record
CVE-2007-2589
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4.9a allows remote attackers to send e-mails from arbitrary users via certain data in the SRC attribute of an IMG element.

Record
CVE-2007-2589
Updated
2026-11-02
EUVDEUVD-2007-2582 No score

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4.9a allows remote attackers to send e-mails from arbitrary users via certain data in the SRC attribute of an IMG element.

Record
EUVD-2007-2582
Updated
2026-11-03
GitHub AdvisoriesGHSA-829x-7jw5-28q3 No score

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4...

Cross-site request forgery (CSRF) vulnerability in compose.php in SquirrelMail 1.4.0 through 1.4.9a allows remote attackers to send e-mails from arbitrary users via certain data in the SRC attribute of an IMG element.

Record
GHSA-829x-7jw5-28q3
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squirrelmail
Debian:3.1
before 2:1.4.4-11, plus listed versions
2:1.4.4-102:1.4.4-52:1.4.4-62:1.4.4-6sarge12:1.4.4-72:1.4.4-82:1.4.4-9
2:1.4.4-11
squirrelmail
Debian:4.0
before 2:1.4.9a-2, plus listed versions
2:1.4.9a-1
2:1.4.9a-2
squirrelmail
Red Hat:enterprise_linux:3::as
before 0:1.4.8-6.el3
0:1.4.8-6.el3
squirrelmail
Red Hat:enterprise_linux:3::desktop
before 0:1.4.8-6.el3
0:1.4.8-6.el3
squirrelmail
Red Hat:enterprise_linux:3::es
before 0:1.4.8-6.el3
0:1.4.8-6.el3
squirrelmail
Red Hat:enterprise_linux:3::ws
before 0:1.4.8-6.el3
0:1.4.8-6.el3
squirrelmail
Red Hat:enterprise_linux:4::as
before 0:1.4.8-4.0.1.el4
0:1.4.8-4.0.1.el4
squirrelmail
Red Hat:enterprise_linux:4::desktop
before 0:1.4.8-4.0.1.el4
0:1.4.8-4.0.1.el4
squirrelmail
Red Hat:enterprise_linux:4::es
before 0:1.4.8-4.0.1.el4
0:1.4.8-4.0.1.el4
squirrelmail
Red Hat:enterprise_linux:4::ws
before 0:1.4.8-4.0.1.el4
0:1.4.8-4.0.1.el4
squirrelmail
Red Hat:enterprise_linux:5::client_workstation
before 0:1.4.8-4.0.1.el5
0:1.4.8-4.0.1.el5
squirrelmail
Red Hat:enterprise_linux:5::server
before 0:1.4.8-4.0.1.el5
0:1.4.8-4.0.1.el5

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-2589 is a medium vulnerability (CVSS 5.0) in Squirrelmail, published May 11, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in squirrelmail 2:1.4.4-11.

References

Show 22 moreShow less
MoveEnter Open