Every CVE Search/ Get API key

CVE-2007-2821

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote...

7.5 HighPublic exploitFix available

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

Exploit likelihood

5.20%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

Record
CVE-2007-2821
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

Record
CVE-2007-2821
Updated
2026-11-02
EUVDEUVD-2007-2813 No score

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

Record
EUVD-2007-2813
Updated
2026-11-03
GitHub AdvisoriesGHSA-v43p-v75m-q643 No score

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote...

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

Record
GHSA-v43p-v75m-q643
Updated
2026-11-02
OSV No score

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

Record
CVE-2007-2821
Updated
2026-11-02
OSVDEBIAN-CVE-2007-2821 No score

SQL injection vulnerability in wp-admin/admin-ajax.php in WordPress before 2.2 allows remote attackers to execute arbitrary SQL commands via the cookie parameter.

Record
DEBIAN-CVE-2007-2821
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 2.2-1
2.2-1
wordpress
Debian:13
before 2.2-1
2.2-1
wordpress
Debian:14
before 2.2-1
2.2-1
wordpress
Debian:4.0
From an advisory covering 4 CVEs
before 2.0.10-1etch1, plus listed versions
2.0.10-12.0.10-1~bpo.12.0.9-1
2.0.10-1etch1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBWordPress Core 2.1.3 - 'admin-ajax.php' SQL Injection Blind Fishing2007-05-21

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
affected, aliases, exploits, facts, references, titleExploit-DB, GitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-2821 is a high vulnerability (CVSS 7.5) in Wordpress, published May 22, 2007. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 5.20%, the 92nd percentile. Fixed in wordpress 2.2-1.

References

Show 7 moreShow less
MoveEnter Open