Every CVE Search/ Get API key

CVE-2007-2873

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual...

1.9 LowFix available

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

Exploit likelihood

0.34%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 1.9

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

Record
CVE-2007-2873
CVSS 2.0
1.9 LowAV:L/AC:M/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

Record
CVE-2007-2873
Updated
2026-11-02
EUVDEUVD-2007-2865 No score

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

Record
EUVD-2007-2865
Updated
2026-11-03
GitHub AdvisoriesGHSA-w3p6-2cc8-h63h No score

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual...

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

Record
GHSA-w3p6-2cc8-h63h
Updated
2026-11-02
OSV No score

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

Record
CVE-2007-2873
Updated
2026-11-02
OSVDEBIAN-CVE-2007-2873 No score

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

Record
DEBIAN-CVE-2007-2873
Updated
2026-11-02
OSVopenSUSE-SU-2024:11395-1 No score

perl-Mail-SpamAssassin-3.4.6-71.3 on GA media

These are all security issues fixed in the perl-Mail-SpamAssassin-3.4.6-71.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11395-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
spamassassin
Debian:12
before 3.2.1-1
3.2.1-1
spamassassin
Debian:13
before 3.2.1-1
3.2.1-1
spamassassin
Debian:14
before 3.2.1-1
3.2.1-1
spamassassin
Red Hat:enterprise_linux:4::as
before 0:3.1.9-1.el4
0:3.1.9-1.el4
spamassassin-debuginfo
Red Hat:enterprise_linux:4::as
before 0:3.1.9-1.el4
0:3.1.9-1.el4
spamassassin
Red Hat:enterprise_linux:4::desktop
before 0:3.1.9-1.el4
0:3.1.9-1.el4
spamassassin-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:3.1.9-1.el4
0:3.1.9-1.el4
spamassassin
Red Hat:enterprise_linux:4::es
before 0:3.1.9-1.el4
0:3.1.9-1.el4
spamassassin-debuginfo
Red Hat:enterprise_linux:4::es
before 0:3.1.9-1.el4
0:3.1.9-1.el4
spamassassin
Red Hat:enterprise_linux:4::ws
before 0:3.1.9-1.el4
0:3.1.9-1.el4
Show 6 moreShow less
Affected packages
PackageAffectedFixed
spamassassin-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:3.1.9-1.el4
0:3.1.9-1.el4
spamassassin
Red Hat:enterprise_linux:5::client
before 0:3.1.9-1.el5
0:3.1.9-1.el5
spamassassin-debuginfo
Red Hat:enterprise_linux:5::client
before 0:3.1.9-1.el5
0:3.1.9-1.el5
spamassassin
Red Hat:enterprise_linux:5::server
before 0:3.1.9-1.el5
0:3.1.9-1.el5
spamassassin-debuginfo
Red Hat:enterprise_linux:5::server
before 0:3.1.9-1.el5
0:3.1.9-1.el5
spamassassin
openSUSE:Tumbleweed
From an advisory covering 9 CVEs
before 3.4.6-71.3
3.4.6-71.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-2873 is a low vulnerability (CVSS 1.9) in Spamassassin, published June 11, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in spamassassin 3.2.1-1.

References

Show 22 moreShow less
MoveEnter Open