CVE-2007-3641
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length...
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length of a certain buffer when processing a malformed pax extension header, which allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PAX or (2) TAR archive that triggers a buffer overflow.
Exploit likelihood
What each source reports
NVD Score used
9.3
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length of a certain buffer when processing a malformed pax extension header, which allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PAX or (2) TAR archive that triggers a buffer overflow.
- Record
CVE-2007-3641- CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length of a certain buffer when processing a malformed pax extension header, which allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PAX or (2) TAR archive that triggers a buffer overflow.
- Record
CVE-2007-3641- Updated
- 2026-11-02
EUVDEUVD-2007-3625 No score
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length of a certain buffer when processing a malformed pax extension header, which allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PAX or (2) TAR archive that triggers a buffer overflow.
- Record
EUVD-2007-3625- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-72gg-m2hj-9c97 No score
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length...
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length of a certain buffer when processing a malformed pax extension header, which allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PAX or (2) TAR archive that triggers a buffer overflow.
- Record
GHSA-72gg-m2hj-9c97- Updated
- 2026-11-02
OSV No score
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length of a certain buffer when processing a malformed pax extension header, which allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PAX or (2) TAR archive that triggers a buffer overflow.
- Record
CVE-2007-3641- Updated
- 2026-11-02
OSVDEBIAN-CVE-2007-3641 No score
archive_read_support_format_tar.c in libarchive before 2.2.4 does not properly compute the length of a certain buffer when processing a malformed pax extension header, which allows user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PAX or (2) TAR archive that triggers a buffer overflow.
- Record
DEBIAN-CVE-2007-3641- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10925-1 No score
bsdtar-3.5.1-1.5 on GA media
These are all security issues fixed in the bsdtar-3.5.1-1.5 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10925-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libarchiveDebian:12 |
before 2.2.4-1 | 2.2.4-1 |
libarchiveDebian:13 |
before 2.2.4-1 | 2.2.4-1 |
libarchiveDebian:14 |
before 2.2.4-1 | 2.2.4-1 |
libarchiveDebian:4.0 From an advisory covering 3 CVEs |
before 1.2.53-2etch1, plus listed versions 1.2.53-21.2.53-2etch1~bpo31+1 |
1.2.53-2etch1 |
bsdtaropenSUSE:Tumbleweed From an advisory covering 12 CVEs |
before 3.5.1-1.5 | 3.5.1-1.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| affected, aliases, facts, references, title | GitHub Advisories, OSV | |
| first indexed | CVE List, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2007-3641 is a high vulnerability (CVSS 9.3) in Freebsd Libarchive, published July 14, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.43%, the 94th percentile. Fixed in libarchive 2.2.4-1.
References
exchange.xforce.ibmcloud.com/vulnerabilities/35405
vupen.com/english/advisories/2007/2521
debian.org/security/2008/dsa-1455
security.freebsd.org/advisories/FreeBSD-SA-07:05.libarchive.asc
security.freebsd.org/patches/SA-07:05/libarchive.patch
secunia.com/advisories/26050
Show 25 moreShow less
securityfocus.com/bid/24885
security.gentoo.org/glsa/glsa-200708-03.xml
bugs.debian.org/cgi-bin/bugreport.cgi?bug=432924
osvdb.org/38092
people.freebsd.org/~kientzle/libarchive
secunia.com/advisories/26062
secunia.com/advisories/26355
securitytracker.com/id?1018379
secunia.com/advisories/28377
novell.com/linux/security/advisories/2007_15_sr.html
nvd.nist.gov/vuln/detail/CVE-2007-3641
github.com/advisories/GHSA-72gg-m2hj-9c97
security-tracker.debian.org/tracker/CVE-2007-3641
suse.com/security/cve/CVE-2006-5680
suse.com/security/cve/CVE-2007-3641
suse.com/security/cve/CVE-2017-14166
suse.com/security/cve/CVE-2017-14501
suse.com/security/cve/CVE-2018-1000877
suse.com/security/cve/CVE-2018-1000878
suse.com/security/cve/CVE-2018-1000879
suse.com/security/cve/CVE-2018-1000880
suse.com/security/cve/CVE-2019-1000019
suse.com/security/cve/CVE-2019-1000020
suse.com/security/cve/CVE-2019-18408
suse.com/security/cve/CVE-2019-19221