Every CVE Search/ Get API key

CVE-2007-4542

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote...

4.3 MediumFix available

CVE-2007-4542 is a medium vulnerability (CVSS 4.3) in University Of Minnesota Mapserver, published August 27, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.60%, the 75th percentile. Fixed in mapserver 4.10.3-1.

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.

Exploit likelihood

1.60%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.

Record
CVE-2007-4542
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.

Record
CVE-2007-4542
Updated
2026-11-02
EUVDEUVD-2007-4525 No score

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.

Record
EUVD-2007-4525
Updated
2026-11-03
GitHub AdvisoriesGHSA-h6vv-phq2-pfpp No score

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote...

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.

Record
GHSA-h6vv-phq2-pfpp
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.

Record
CVE-2007-4542
Updated
2026-11-02
OSVDEBIAN-CVE-2007-4542 No score

Multiple cross-site scripting (XSS) vulnerabilities in MapServer before 4.10.3 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving the (1) processLine function in maptemplate.c and the (2) writeError function in mapserv.c in the mapserv CGI program.

Record
DEBIAN-CVE-2007-4542
Updated
2026-11-02
OSVopenSUSE-SU-2024:11037-1 No score

libjavamapscript-7.6.3-1.2 on GA media

These are all security issues fixed in the libjavamapscript-7.6.3-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11037-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mapserver
Debian:12
before 4.10.3-1
4.10.3-1
mapserver
Debian:13
before 4.10.3-1
4.10.3-1
mapserver
Debian:14
before 4.10.3-1
4.10.3-1
mapserver
Debian:4.0
before 4.10.0-5.1+etch2, plus listed versions
4.10.0-5+etch1
4.10.0-5.1+etch2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02aliases
2026-11-02affected, aliases, facts, references, titleGitHub Advisories, OSV
2026-11-02createdCVE List, NVD

References

Show 11 moreShow less
MoveEnter Open