Every CVE Search/ Get API key

CVE-2007-4657

Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers...

7.5 HighFix available

CVE-2007-4657 is a high vulnerability (CVSS 7.5) in Php, published September 4, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.99%, the 87th percentile. Fixed in php5 5.2.0-8+etch9.

Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers to obtain sensitive information (memory contents) or cause a denial of service (thread crash) via a large len value to the (1) strspn or (2) strcspn function, which triggers an out-of-bounds read. NOTE: this affects different product versions than CVE-2007-3996.

Exploit likelihood

2.99%Down 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers to obtain sensitive information (memory contents) or cause a denial of service (thread crash) via a large len value to the (1) strspn or (2) strcspn function, which triggers an out-of-bounds read. NOTE: this affects different product versions than CVE-2007-3996.

Record
CVE-2007-4657
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119, CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers to obtain sensitive information (memory contents) or cause a denial of service (thread crash) via a large len value to the (1) strspn or (2) strcspn function, which triggers an out-of-bounds read. NOTE: this affects different product versions than CVE-2007-3996.

Record
CVE-2007-4657
Updated
2026-11-02
EUVDEUVD-2007-4639 No score

Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers to obtain sensitive information (memory contents) or cause a denial of service (thread crash) via a large len value to the (1) strspn or (2) strcspn function, which triggers an out-of-bounds read. NOTE: this affects different product versions than CVE-2007-3996.

Record
EUVD-2007-4639
Updated
2026-11-03
GitHub AdvisoriesGHSA-43ww-xqjh-ppmf No score

Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers...

Multiple integer overflows in PHP 4 before 4.4.8, and PHP 5 before 5.2.4, allow remote attackers to obtain sensitive information (memory contents) or cause a denial of service (thread crash) via a large len value to the (1) strspn or (2) strcspn function, which triggers an out-of-bounds read. NOTE: this affects different product versions than CVE-2007-3996.

Record
GHSA-43ww-xqjh-ppmf
Weakness
CWE-119
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php5
Debian:4.0
before 5.2.0-8+etch9, plus listed versions
5.2.0-8+etch15.2.0-8+etch35.2.0-8+etch45.2.0-8+etch5~pu15.2.0-8+etch65.2.0-8+etch75.2.0-8+etch85.2.0-8+etch9~bpo31+1
5.2.0-8+etch9
php4
Debian:4.0
before 6:4.4.4-8+etch6, plus listed versions
6:4.4.4-8+etch16:4.4.4-8+etch26:4.4.4-8+etch36:4.4.4-8+etch4
6:4.4.4-8+etch6
php5
Debian:5.0
before 5.2.3-1+lenny1
5.2.3-1+lenny1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02aliases
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 25 moreShow less
MoveEnter Open