Every CVE Search/ Get API key

CVE-2007-4743

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT...

10.0 HighFix available

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Exploit likelihood

4.61%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Record
CVE-2007-4743
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Record
CVE-2007-4743
Updated
2026-11-02
EUVDEUVD-2007-4724 No score

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Record
EUVD-2007-4724
Updated
2026-11-03
GitHub AdvisoriesGHSA-2pm5-h4rp-cjq3 No score

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT...

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Record
GHSA-2pm5-h4rp-cjq3
Weakness
CWE-119
Updated
2026-11-02
OSV No score

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Record
CVE-2007-4743
Updated
2026-11-02
OSVDEBIAN-CVE-2007-4743 No score

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Record
DEBIAN-CVE-2007-4743
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
krb5
Debian:12
before 1.6.dfsg.1-7
1.6.dfsg.1-7
krb5
Debian:13
before 1.6.dfsg.1-7
1.6.dfsg.1-7
krb5
Debian:14
before 1.6.dfsg.1-7
1.6.dfsg.1-7
krb5
Debian:4.0
From an advisory covering 2 CVEs
before 1.4.4-7etch4, plus listed versions
1.4.4-7etch11.4.4-7etch21.4.4-7etch3
1.4.4-7etch4
librpcsecgss
Debian:4.0
before 0.14-2etch3, plus listed versions
0.14-20.14-2etch10.14-2etch2
0.14-2etch3
krb5
Red Hat:enterprise_linux:5::client_workstation
before 0:1.5-29
0:1.5-29
krb5-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:1.5-29
0:1.5-29
krb5-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:1.5-29
0:1.5-29
krb5-server
Red Hat:enterprise_linux:5::client_workstation
before 0:1.5-29
0:1.5-29
krb5
Red Hat:enterprise_linux:5::client
before 0:1.5-29
0:1.5-29
Show 9 moreShow less
Affected packages
PackageAffectedFixed
krb5-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.5-29
0:1.5-29
krb5-libs
Red Hat:enterprise_linux:5::client
before 0:1.5-29
0:1.5-29
krb5-workstation
Red Hat:enterprise_linux:5::client
before 0:1.5-29
0:1.5-29
krb5
Red Hat:enterprise_linux:5::server
before 0:1.5-29
0:1.5-29
krb5-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.5-29
0:1.5-29
krb5-devel
Red Hat:enterprise_linux:5::server
before 0:1.5-29
0:1.5-29
krb5-libs
Red Hat:enterprise_linux:5::server
before 0:1.5-29
0:1.5-29
krb5-server
Red Hat:enterprise_linux:5::server
before 0:1.5-29
0:1.5-29
krb5-workstation
Red Hat:enterprise_linux:5::server
before 0:1.5-29
0:1.5-29

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
affected, aliases, facts, published, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-4743 is a high vulnerability (CVSS 10.0) in Mit Kerberos 5, published September 6, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.61%, the 91st percentile. Fixed in krb5 1.6.dfsg.1-7.

References

Show 20 moreShow less
MoveEnter Open