Every CVE Search/ Get API key

CVE-2007-4766

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow...

7.5 HighFix available

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.

Exploit likelihood

4.16%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.

Record
CVE-2007-4766
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.

Record
CVE-2007-4766
Updated
2026-11-02
EUVDEUVD-2007-4747 No score

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.

Record
EUVD-2007-4747
Updated
2026-11-03
GitHub AdvisoriesGHSA-ppf2-g285-2xj9 No score

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow...

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.

Record
GHSA-ppf2-g285-2xj9
Updated
2026-11-02
OSV No score

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.

Record
CVE-2007-4766
Updated
2026-11-02
OSVDEBIAN-CVE-2007-4766 No score

Multiple integer overflows in Perl-Compatible Regular Expression (PCRE) library before 7.3 allow context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via unspecified escape (backslash) sequences.

Record
DEBIAN-CVE-2007-4766
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glib2.0
Debian:12
before 2.14.3-1
2.14.3-1
glib2.0
Debian:13
before 2.14.3-1
2.14.3-1
glib2.0
Debian:14
before 2.14.3-1
2.14.3-1
pcre3
Debian:12
before 7.3-1
7.3-1
pcre3
Debian:3.1
From an advisory covering 7 CVEs
before 4.5+7.4-1, plus listed versions
4.5-1.24.5-1.2sarge1
4.5+7.4-1
pcre3
Debian:4.0
From an advisory covering 7 CVEs
before 6.7+7.4-2, plus listed versions
6.7+7.4-16.7-1
6.7+7.4-2
kazehakase
Debian:4.0
From an advisory covering 10 CVEs
before 0.4.2-1etch1, plus listed versions
0.4.2-1
0.4.2-1etch1
pcre3
Debian:5.0
From an advisory covering 7 CVEs
before 6.7+7.4-2+lenny1
6.7+7.4-2+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-4766 is a high vulnerability (CVSS 7.5) in Pcre, published November 5, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.16%, the 90th percentile. Fixed in glib2.0 2.14.3-1.

References

Show 41 moreShow less
MoveEnter Open