Every CVE Search/ Get API key

CVE-2007-4767

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length...

5.0 MediumFix available

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

Exploit likelihood

5.07%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

Record
CVE-2007-4767
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

Record
CVE-2007-4767
Updated
2026-11-02
EUVDEUVD-2007-4748 No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

Record
EUVD-2007-4748
Updated
2026-11-03
GitHub AdvisoriesGHSA-9cw9-v886-c24m No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length...

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

Record
GHSA-9cw9-v886-c24m
Updated
2026-11-02
OSV No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

Record
CVE-2007-4767
Updated
2026-11-02
OSVDEBIAN-CVE-2007-4767 No score

Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

Record
DEBIAN-CVE-2007-4767
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glib2.0
Debian:12
before 2.14.3-1
2.14.3-1
glib2.0
Debian:13
before 2.14.3-1
2.14.3-1
glib2.0
Debian:14
before 2.14.3-1
2.14.3-1
pcre3
Debian:12
before 7.3-1
7.3-1
pcre3
Debian:3.1
From an advisory covering 7 CVEs
before 4.5+7.4-1, plus listed versions
4.5-1.24.5-1.2sarge1
4.5+7.4-1
pcre3
Debian:4.0
From an advisory covering 7 CVEs
before 6.7+7.4-2, plus listed versions
6.7+7.4-16.7-1
6.7+7.4-2
kazehakase
Debian:4.0
From an advisory covering 10 CVEs
before 0.4.2-1etch1, plus listed versions
0.4.2-1
0.4.2-1etch1
pcre3
Debian:5.0
From an advisory covering 7 CVEs
before 6.7+7.4-2+lenny1
6.7+7.4-2+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-4767 is a medium vulnerability (CVSS 5.0) in Pcre, published November 5, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.07%, the 92nd percentile. Fixed in glib2.0 2.14.3-1.

References

Show 41 moreShow less
MoveEnter Open