Every CVE Search/ Get API key

CVE-2007-4768

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows...

6.8 MediumFix available

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

Exploit likelihood

4.10%Down 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

Record
CVE-2007-4768
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

Record
CVE-2007-4768
Updated
2026-11-02
EUVDEUVD-2007-4749 No score

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

Record
EUVD-2007-4749
Updated
2026-11-03
GitHub AdvisoriesGHSA-jq5c-rgv9-cw8p No score

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows...

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

Record
GHSA-jq5c-rgv9-cw8p
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

Record
CVE-2007-4768
Updated
2026-11-02
OSVDEBIAN-CVE-2007-4768 No score

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

Record
DEBIAN-CVE-2007-4768
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glib2.0
Debian:12
before 2.14.3-1
2.14.3-1
glib2.0
Debian:13
before 2.14.3-1
2.14.3-1
glib2.0
Debian:14
before 2.14.3-1
2.14.3-1
pcre3
Debian:12
before 7.3-1
7.3-1
pcre3
Debian:3.1
From an advisory covering 7 CVEs
before 4.5+7.4-1, plus listed versions
4.5-1.24.5-1.2sarge1
4.5+7.4-1
pcre3
Debian:4.0
From an advisory covering 7 CVEs
before 6.7+7.4-2, plus listed versions
6.7+7.4-16.7-1
6.7+7.4-2
kazehakase
Debian:4.0
From an advisory covering 10 CVEs
before 0.4.2-1etch1, plus listed versions
0.4.2-1
0.4.2-1etch1
pcre3
Debian:5.0
From an advisory covering 7 CVEs
before 6.7+7.4-2+lenny1
6.7+7.4-2+lenny1
flash-plugin
Red Hat:rhel_extras:3
From an advisory covering 8 CVEs
before 0:9.0.115.0-1.el3.with.oss
0:9.0.115.0-1.el3.with.oss
flash-plugin
Red Hat:rhel_extras:4
From an advisory covering 8 CVEs
before 0:9.0.115.0-1.el4
0:9.0.115.0-1.el4
flash-plugin
Red Hat:rhel_extras:5::client
From an advisory covering 8 CVEs
before 0:9.0.115.0-1.el5
0:9.0.115.0-1.el5
flash-plugin
Red Hat:rhel_extras:5::server
From an advisory covering 8 CVEs
before 0:9.0.115.0-1.el5
0:9.0.115.0-1.el5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-4768 is a medium vulnerability (CVSS 6.8) in Pcre, published November 5, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.10%, the 90th percentile. Fixed in glib2.0 2.14.3-1.

References

Show 91 moreShow less
MoveEnter Open