Every CVE Search/ Get API key

CVE-2007-5208

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10...

7.6 HighPublic exploitFix available

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Exploit likelihood

67.3%Down 14.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.6

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Record
CVE-2007-5208
CVSS 2.0
7.6 HighAV:N/AC:H/Au:N/C:C/I:C/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Record
CVE-2007-5208
Updated
2026-11-02
EUVDEUVD-2007-5188 No score

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Record
EUVD-2007-5188
Updated
2026-11-03
GitHub AdvisoriesGHSA-qjxj-rc6r-r77w No score

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10...

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Record
GHSA-qjxj-rc6r-r77w
Weakness
CWE-20
Updated
2026-11-02
OSV No score

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Record
CVE-2007-5208
Updated
2026-11-02
OSVDEBIAN-CVE-2007-5208 No score

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Record
DEBIAN-CVE-2007-5208
Updated
2026-11-02
OSVopenSUSE-SU-2024:10847-1 No score

hplip-3.21.6-1.2 on GA media

These are all security issues fixed in the hplip-3.21.6-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10847-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
hplip
Debian:12
before 1.6.10-4.3
1.6.10-4.3
hplip
Debian:13
before 1.6.10-4.3
1.6.10-4.3
hplip
Debian:4.0
before 1.6.10-3etch1, plus listed versions
1.6.10-3
1.6.10-3etch1
hplip
Debian:5.0
before 1.6.10-4.2+lenny1
1.6.10-4.2+lenny1
hpijs
Red Hat:enterprise_linux:5::client
before 1:1.6.7-4.1.el5_0.3
1:1.6.7-4.1.el5_0.3
hplip
Red Hat:enterprise_linux:5::client
before 0:1.6.7-4.1.el5_0.3
0:1.6.7-4.1.el5_0.3
hplip-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.6.7-4.1.el5_0.3
0:1.6.7-4.1.el5_0.3
libsane-hpaio
Red Hat:enterprise_linux:5::client
before 0:1.6.7-4.1.el5_0.3
0:1.6.7-4.1.el5_0.3
hpijs
Red Hat:enterprise_linux:5::server
before 1:1.6.7-4.1.el5_0.3
1:1.6.7-4.1.el5_0.3
hplip
Red Hat:enterprise_linux:5::server
before 0:1.6.7-4.1.el5_0.3
0:1.6.7-4.1.el5_0.3
hplip-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.6.7-4.1.el5_0.3
0:1.6.7-4.1.el5_0.3
libsane-hpaio
Red Hat:enterprise_linux:5::server
before 0:1.6.7-4.1.el5_0.3
0:1.6.7-4.1.el5_0.3
hplip
openSUSE:Tumbleweed
before 3.21.6-1.2
3.21.6-1.2

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, exploits, facts, references, titleExploit-DB, GitHub Advisories, Metasploit, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-5208 is a high vulnerability (CVSS 7.6) in Hp Linux Imaging And Printing Project, published October 13, 2007. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 67.3%, the 99th percentile. Fixed in hplip 1.6.10-4.3.

References

Show 27 moreShow less
MoveEnter Open