Every CVE Search/ Get API key

CVE-2007-5710

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows...

2.6 LowPublic exploitFix available

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.

Exploit likelihood

7.00%Up 3.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.

Record
CVE-2007-5710
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.

Record
CVE-2007-5710
Updated
2026-11-02
EUVDEUVD-2007-5682 No score

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.

Record
EUVD-2007-5682
Updated
2026-11-03
GitHub AdvisoriesGHSA-v5g5-w9j9-7c3g No score

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows...

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.

Record
GHSA-v5g5-w9j9-7c3g
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.

Record
CVE-2007-5710
Updated
2026-11-02
OSVDEBIAN-CVE-2007-5710 No score

Cross-site scripting (XSS) vulnerability in wp-admin/edit-post-rows.php in WordPress 2.3 allows remote attackers to inject arbitrary web script or HTML via the posts_columns array parameter.

Record
DEBIAN-CVE-2007-5710
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 2.3.1-1
2.3.1-1
wordpress
Debian:13
before 2.3.1-1
2.3.1-1
wordpress
Debian:14
before 2.3.1-1
2.3.1-1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBWordPress Core 2.3 - 'Edit-Post-Rows.php' Cross-Site Scripting2007-10-29

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, exploits, facts, references, titleExploit-DB, GitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-5710 is a low vulnerability (CVSS 2.6) in Wordpress, published October 30, 2007. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 7.00%, the 94th percentile. Fixed in wordpress 2.3.1-1.

References

Show 5 moreShow less
MoveEnter Open