Every CVE Search/ Get API key

CVE-2007-5742

Directory traversal vulnerability in the WML engine preprocessor for Wesnoth 1.2.x before 1.2.8,...

9.0 HighFix available

Directory traversal vulnerability in the WML engine preprocessor for Wesnoth 1.2.x before 1.2.8, and 1.3.x before 1.3.12, allows remote attackers to read arbitrary files via ".." sequences in unknown vectors.

Exploit likelihood

2.83%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.0

Directory traversal vulnerability in the WML engine preprocessor for Wesnoth 1.2.x before 1.2.8, and 1.3.x before 1.3.12, allows remote attackers to read arbitrary files via ".." sequences in unknown vectors.

Record
CVE-2007-5742
CVSS 2.0
9.0 HighAV:N/AC:L/Au:N/C:P/I:P/A:C
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in the WML engine preprocessor for Wesnoth 1.2.x before 1.2.8, and 1.3.x before 1.3.12, allows remote attackers to read arbitrary files via ".." sequences in unknown vectors.

Record
CVE-2007-5742
Updated
2026-11-02
EUVDEUVD-2007-5712 No score

Directory traversal vulnerability in the WML engine preprocessor for Wesnoth 1.2.x before 1.2.8, and 1.3.x before 1.3.12, allows remote attackers to read arbitrary files via ".." sequences in unknown vectors.

Record
EUVD-2007-5712
Updated
2026-11-03
GitHub AdvisoriesGHSA-vx59-6637-4544 No score

Directory traversal vulnerability in the WML engine preprocessor for Wesnoth 1.2.x before 1.2.8,...

Directory traversal vulnerability in the WML engine preprocessor for Wesnoth 1.2.x before 1.2.8, and 1.3.x before 1.3.12, allows remote attackers to read arbitrary files via ".." sequences in unknown vectors.

Record
GHSA-vx59-6637-4544
Weakness
CWE-22
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wesnoth
Debian:3.1
before 0.9.0-7, plus listed versions
0.9.0-50.9.0-6
0.9.0-7
wesnoth
Debian:4.0
before 1.2-3, plus listed versions
1.2-11.2-2
1.2-3
wesnoth
Debian:5.0
before 1:1.2.7-2+lenny1
1:1.2.7-2+lenny1

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, published, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-5742 is a high vulnerability (CVSS 9.0) in Wesnoth, published December 1, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.83%, the 86th percentile. Fixed in wesnoth 0.9.0-7.

References

Show 9 moreShow less
MoveEnter Open