Every CVE Search/ Get API key

CVE-2007-6421

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache...

3.5 LowFix available

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via the (1) ss, (2) wr, or (3) rr parameters, or (4) the URL.

Exploit likelihood

8.32%Up 4.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via the (1) ss, (2) wr, or (3) rr parameters, or (4) the URL.

Record
CVE-2007-6421
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via the (1) ss, (2) wr, or (3) rr parameters, or (4) the URL.

Record
CVE-2007-6421
Updated
2026-11-02
EUVDEUVD-2007-6387 No score

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via the (1) ss, (2) wr, or (3) rr parameters, or (4) the URL.

Record
EUVD-2007-6387
Updated
2026-11-03
GitHub AdvisoriesGHSA-g65v-mwjw-wg6c No score

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache...

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via the (1) ss, (2) wr, or (3) rr parameters, or (4) the URL.

Record
GHSA-g65v-mwjw-wg6c
Weakness
CWE-79
Updated
2026-11-02
OSVBELL-CVE-2007-6421 3.5

CVE-2007-6421 does not affect BellSoft software

Record
BELL-CVE-2007-6421
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via the (1) ss, (2) wr, or (3) rr parameters, or (4) the URL.

Record
CVE-2007-6421
Updated
2026-11-02
OSVDEBIAN-CVE-2007-6421 No score

Cross-site scripting (XSS) vulnerability in balancer-manager in mod_proxy_balancer in the Apache HTTP Server 2.2.0 through 2.2.6 allows remote attackers to inject arbitrary web script or HTML via the (1) ss, (2) wr, or (3) rr parameters, or (4) the URL.

Record
DEBIAN-CVE-2007-6421
Updated
2026-11-02
OSVopenSUSE-SU-2024:10623-1 No score

apache2-2.4.49-1.1 on GA media

These are all security issues fixed in the apache2-2.4.49-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10623-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache2
Debian:12
before 2.2.8-1
2.2.8-1
apache2
Debian:13
before 2.2.8-1
2.2.8-1
apache2
Debian:14
before 2.2.8-1
2.2.8-1
httpd
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd-debuginfo
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd-devel
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd-manual
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd
Red Hat:enterprise_linux:5::client
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd-debuginfo
Red Hat:enterprise_linux:5::client
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
mod_ssl
Red Hat:enterprise_linux:5::client
From an advisory covering 6 CVEs
before 1:2.2.3-11.el5_1.3
1:2.2.3-11.el5_1.3
Show 11 moreShow less
Affected packages
PackageAffectedFixed
httpd
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd-debuginfo
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd-devel
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
httpd-manual
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 0:2.2.3-11.el5_1.3
0:2.2.3-11.el5_1.3
mod_ssl
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 1:2.2.3-11.el5_1.3
1:2.2.3-11.el5_1.3
httpd
Red Hat:rhel_application_stack:2
From an advisory covering 5 CVEs
before 0:2.2.4-9.el5s2
0:2.2.4-9.el5s2
httpd-debuginfo
Red Hat:rhel_application_stack:2
From an advisory covering 5 CVEs
before 0:2.2.4-9.el5s2
0:2.2.4-9.el5s2
httpd-devel
Red Hat:rhel_application_stack:2
From an advisory covering 5 CVEs
before 0:2.2.4-9.el5s2
0:2.2.4-9.el5s2
httpd-manual
Red Hat:rhel_application_stack:2
From an advisory covering 5 CVEs
before 0:2.2.4-9.el5s2
0:2.2.4-9.el5s2
mod_ssl
Red Hat:rhel_application_stack:2
From an advisory covering 5 CVEs
before 1:2.2.4-9.el5s2
1:2.2.4-9.el5s2
apache2
openSUSE:Tumbleweed
From an advisory covering 27 CVEs
before 2.4.49-1.1
2.4.49-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-6421 is a low vulnerability (CVSS 3.5) in Apache Http Server, published January 8, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.32%, the 94th percentile. Fixed in apache2 2.2.8-1.

References

Show 105 moreShow less
MoveEnter Open