Every CVE Search/ Get API key

CVE-2007-6610

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might...

10.0 HighFix available

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might allow context-dependent attackers to execute arbitrary commands via shell metacharacters in a filename argument. NOTE: this might only be a vulnerability when unp is invoked by a third party product.

Exploit likelihood

2.28%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might allow context-dependent attackers to execute arbitrary commands via shell metacharacters in a filename argument. NOTE: this might only be a vulnerability when unp is invoked by a third party product.

Record
CVE-2007-6610
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might allow context-dependent attackers to execute arbitrary commands via shell metacharacters in a filename argument. NOTE: this might only be a vulnerability when unp is invoked by a third party product.

Record
CVE-2007-6610
Updated
2026-11-02
EUVDEUVD-2007-6576 No score

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might allow context-dependent attackers to execute arbitrary commands via shell metacharacters in a filename argument. NOTE: this might only be a vulnerability when unp is invoked by a third party product.

Record
EUVD-2007-6576
Updated
2026-11-03
GitHub AdvisoriesGHSA-r9r9-p68f-q4fg No score

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might...

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might allow context-dependent attackers to execute arbitrary commands via shell metacharacters in a filename argument. NOTE: this might only be a vulnerability when unp is invoked by a third party product.

Record
GHSA-r9r9-p68f-q4fg
Updated
2026-11-02
OSV No score

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might allow context-dependent attackers to execute arbitrary commands via shell metacharacters in a filename argument. NOTE: this might only be a vulnerability when unp is invoked by a third party product.

Record
CVE-2007-6610
Updated
2026-11-02
OSVDEBIAN-CVE-2007-6610 No score

unp 1.0.12, and other versions before 1.0.14, does not properly escape file names, which might allow context-dependent attackers to execute arbitrary commands via shell metacharacters in a filename argument. NOTE: this might only be a vulnerability when unp is invoked by a third party product.

Record
DEBIAN-CVE-2007-6610
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
unp
Debian:12
before 1.0.13
1.0.13
unp
Debian:13
before 1.0.13
1.0.13
unp
Debian:14
before 1.0.13
1.0.13

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-6610 is a high vulnerability (CVSS 10.0) in Debian Unp, published January 3, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.28%, the 83rd percentile. Fixed in unp 1.0.13.

References

Show 4 moreShow less
MoveEnter Open