Every CVE Search/ Get API key

CVE-2007-6731

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code...

10.0 HighPublic exploitFix available

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.

Exploit likelihood

14.1%Up 6.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.

Record
CVE-2007-6731
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.

Record
CVE-2007-6731
Updated
2026-11-02
EUVDEUVD-2007-6693 No score

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.

Record
EUVD-2007-6693
Updated
2026-11-03
GitHub AdvisoriesGHSA-5xjw-36fw-5xm4 No score

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code...

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.

Record
GHSA-5xjw-36fw-5xm4
Weakness
CWE-94
Updated
2026-11-02
OSV No score

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.

Record
CVE-2007-6731
Updated
2026-11-02
OSVDEBIAN-CVE-2007-6731 No score

Extended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.

Record
DEBIAN-CVE-2007-6731
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xmp
Debian:12
before 2.6.1-1
2.6.1-1
xmp
Debian:13
before 2.6.1-1
2.6.1-1
xmp
Debian:14
before 2.6.1-1
2.6.1-1

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
affected, aliases, exploits, facts, references, titleExploit-DB, GitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-6731 is a high vulnerability (CVSS 10.0) in Claudio Matsuoka Extended Module Player, published September 13, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 14.1%, the 96th percentile. Fixed in xmp 2.6.1-1.

References

MoveEnter Open