CVE-2008-0386
Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands...
Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in a URL argument to (1) xdg-open or (2) xdg-email.
Exploit likelihood
What each source reports
NVD Score used
6.8
Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in a URL argument to (1) xdg-open or (2) xdg-email.
- Record
CVE-2008-0386- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in a URL argument to (1) xdg-open or (2) xdg-email.
- Record
CVE-2008-0386- Updated
- 2026-11-02
EUVDEUVD-2008-0396 No score
Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in a URL argument to (1) xdg-open or (2) xdg-email.
- Record
EUVD-2008-0396- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w4vh-2xrr-v7qg No score
Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands...
Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in a URL argument to (1) xdg-open or (2) xdg-email.
- Record
GHSA-w4vh-2xrr-v7qg- Weakness
- CWE-20
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11518-1 No score
xdg-utils-1.1.3+20201113-1.2 on GA media
These are all security issues fixed in the xdg-utils-1.1.3+20201113-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11518-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xdg-utilsopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 1.1.3+20201113-1.2 | 1.1.3+20201113-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-0386 is a medium vulnerability (CVSS 6.8) in Gentoo Xdg-utils, published February 4, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.17%, the 88th percentile. No source names a fixed version.
References
webcvs.freedesktop.org/portland/portland/xdg-utils/scripts/xdg-open?view=log
webcvs.freedesktop.org/portland/portland/xdg-utils/scripts/xdg-email?r1=1.36&r2=1.37
secunia.com/advisories/29048
security.gentoo.org/glsa/glsa-200801-21.xml
secunia.com/advisories/28728
webcvs.freedesktop.org/portland/portland/xdg-utils/scripts/xdg-email.in?r1=1.24&r2=1.25
Show 15 moreShow less
vupen.com/english/advisories/2008/0342
securitytracker.com/id?1019284
webcvs.freedesktop.org/portland/portland/xdg-utils/scripts/xdg-open?r1=1.32&r2=1.33
mandriva.com/security/advisories?name=MDVSA-2008:031
bugs.gentoo.org/show_bug.cgi?id=207331
webcvs.freedesktop.org/portland/portland/xdg-utils/scripts/xdg-open.in?r1=1.17&r2=1.18
lists.opensuse.org/opensuse-security-announce/2008-02/msg00008.html
securityfocus.com/bid/27528
webcvs.freedesktop.org/portland/portland/xdg-utils/scripts/xdg-email.in?view=log
bugzilla.redhat.com/show_bug.cgi?id=429513
secunia.com/advisories/28638
nvd.nist.gov/vuln/detail/CVE-2008-0386
github.com/advisories/GHSA-w4vh-2xrr-v7qg
suse.com/security/cve/CVE-2008-0386
suse.com/security/cve/CVE-2017-18266