Every CVE Search/ Get API key

CVE-2008-0928

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests,...

4.7 MediumFix available

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

Exploit likelihood

0.37%Down 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.7

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

Record
CVE-2008-0928
CVSS 2.0
4.7 MediumAV:L/AC:M/Au:N/C:C/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

Record
CVE-2008-0928
Updated
2026-11-02
EUVDEUVD-2008-0935 No score

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

Record
EUVD-2008-0935
Updated
2026-11-03
GitHub AdvisoriesGHSA-4gr3-prqp-v6r3 No score

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests,...

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

Record
GHSA-4gr3-prqp-v6r3
Updated
2026-11-02
OSV No score

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

Record
CVE-2008-0928
Updated
2026-11-02
OSVDEBIAN-CVE-2008-0928 No score

Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.

Record
DEBIAN-CVE-2008-0928
Updated
2026-11-02
OSVopenSUSE-SU-2024:10233-1 No score

qemu-2.6.1-1.5 on GA media

These are all security issues fixed in the qemu-2.6.1-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10233-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10285-1 No score

qemu-linux-user-2.6.1-1.5 on GA media

These are all security issues fixed in the qemu-linux-user-2.6.1-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10285-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qemu
Debian:12
before 0.9.1+svn20081207-1
0.9.1+svn20081207-1
qemu
Debian:13
before 0.9.1+svn20081207-1
0.9.1+svn20081207-1
qemu
Debian:14
before 0.9.1+svn20081207-1
0.9.1+svn20081207-1
qemu
Debian:4.0
From an advisory covering 3 CVEs
before 0.8.2-4etch3, plus listed versions
0.8.2-40.8.2-4etch10.8.2-4etch2
0.8.2-4etch3
qemu
Debian:5.0
From an advisory covering 3 CVEs
before 0.9.1-10lenny1, plus listed versions
0.9.1-100.9.1-10lenny1~bpo40+1
0.9.1-10lenny1
kvm
Debian:5.0
From an advisory covering 6 CVEs
before 60+dfsg-1+lenny1
60+dfsg-1+lenny1
xen
Red Hat:rhel_virtualization:5::client
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen-debuginfo
Red Hat:rhel_virtualization:5::client
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen-devel
Red Hat:rhel_virtualization:5::client
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen
Red Hat:enterprise_linux:5::client
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
Show 10 moreShow less
Affected packages
PackageAffectedFixed
xen-debuginfo
Red Hat:enterprise_linux:5::client
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen-libs
Red Hat:enterprise_linux:5::client
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen
Red Hat:rhel_virtualization:5::server
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen-debuginfo
Red Hat:rhel_virtualization:5::server
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen-devel
Red Hat:rhel_virtualization:5::server
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen-debuginfo
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
xen-libs
Red Hat:enterprise_linux:5::server
From an advisory covering 6 CVEs
before 0:3.0.3-41.el5_1.5
0:3.0.3-41.el5_1.5
qemu
openSUSE:Tumbleweed
From an advisory covering 53 CVEs
before 2.6.1-1.5
2.6.1-1.5
qemu-linux-user
openSUSE:Tumbleweed
From an advisory covering 12 CVEs
before 2.6.1-1.5
2.6.1-1.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
aliases
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-0928 is a medium vulnerability (CVSS 4.7) in Qemu, published March 3, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 30th percentile. Fixed in qemu 0.9.1+svn20081207-1.

References

Show 98 moreShow less
MoveEnter Open