Every CVE Search/ Get API key

CVE-2008-1530

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and...

9.3 HighFix available

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

Exploit likelihood

4.30%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

Record
CVE-2008-1530
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

Record
CVE-2008-1530
Updated
2026-11-02
EUVDEUVD-2008-1531 No score

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

Record
EUVD-2008-1531
Updated
2026-11-03
GitHub AdvisoriesGHSA-9r93-hrx4-h834 No score

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and...

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

Record
GHSA-9r93-hrx4-h834
Updated
2026-11-02
OSV No score

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

Record
CVE-2008-1530
Updated
2026-11-02
OSVDEBIAN-CVE-2008-1530 No score

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

Record
DEBIAN-CVE-2008-1530
Updated
2026-11-02
OSVopenSUSE-SU-2024:10815-1 No score

dirmngr-2.2.27-2.4 on GA media

These are all security issues fixed in the dirmngr-2.2.27-2.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10815-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnupg2
Debian:12
before 2.0.9-1
2.0.9-1
gnupg2
Debian:13
before 2.0.9-1
2.0.9-1
gnupg2
Debian:14
before 2.0.9-1
2.0.9-1
gpg2
openSUSE:Tumbleweed
From an advisory covering 8 CVEs
before 2.2.27-2.4
2.2.27-2.4

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-1530 is a high vulnerability (CVSS 9.3) in Gnupg, published March 27, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.30%, the 91st percentile. Fixed in gnupg2 2.0.9-1.

References

Show 13 moreShow less
MoveEnter Open