Every CVE Search/ Get API key

CVE-2008-1688

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to...

7.5 HighFix available

CVE-2008-1688 is a high vulnerability (CVSS 7.5) in Gnu M4, published April 9, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.96%, the 87th percentile. Fixed in m4 1.4.19-3.root.io.2.

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Exploit likelihood

2.96%Down 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Record
CVE-2008-1688
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Record
CVE-2008-1688
Updated
2026-11-02
EUVDEUVD-2008-1689 No score

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Record
EUVD-2008-1689
Updated
2026-11-03
GitHub AdvisoriesGHSA-rq5m-h657-fcmc No score

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to...

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Record
GHSA-rq5m-h657-fcmc
Updated
2026-11-02
OSV No score

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Record
CVE-2008-1688
Updated
2026-11-02
OSVDEBIAN-CVE-2008-1688 No score

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Record
DEBIAN-CVE-2008-1688
Updated
2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2008-1688 No score

CVE-2008-1688 in m4 - Patched by Root

Root has patched CVE-2008-1688 in the m4 package for Root:Debian:12. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-12-CVE-2008-1688
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
m4
Debian:12
All versions, plus listed versions
1.4.19-31.4.19-41.4.19-4+hurd.11.4.19-51.4.19-6
Show 5 moreShow less
1.4.19-71.4.19-81.4.20-11.4.20-21.4.21-1
None known
m4
Debian:13
All versions, plus listed versions
1.4.19-81.4.20-11.4.20-21.4.21-1
None known
m4
Debian:14
All versions, plus listed versions
1.4.19-81.4.20-11.4.20-21.4.21-1
None known
m4
Root:Debian:12
before 1.4.19-3.root.io.2
1.4.19-3.root.io.21.4.19-3.root.io.11.4.19-3.root.io.31.4.19-3.root.io.41.4.19-3.aikido.5
rootio-m4
Root:Debian:12
before 1.4.19-3.root.io.2
1.4.19-3.root.io.21.4.19-3.root.io.11.4.19-3.root.io.31.4.19-3.root.io.41.4.19-3.aikido.5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
MoveEnter Open