Every CVE Search/ Get API key

CVE-2008-2285

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys...

5.0 MediumFix available

CVE-2008-2285 is a medium vulnerability (CVSS 5.0) in Ubuntu Linux, published May 14, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in openssh 1:4.7p1-10.

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys lines that contain options, which makes it easier for remote attackers to exploit CVE-2008-0166 by guessing a key that was not identified by this tool.

Exploit likelihood

1.69%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys lines that contain options, which makes it easier for remote attackers to exploit CVE-2008-0166 by guessing a key that was not identified by this tool.

Record
CVE-2008-2285
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-310
Updated
2026-11-02
CVE List No score

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys lines that contain options, which makes it easier for remote attackers to exploit CVE-2008-0166 by guessing a key that was not identified by this tool.

Record
CVE-2008-2285
Updated
2026-11-02
EUVDEUVD-2008-2282 No score

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys lines that contain options, which makes it easier for remote attackers to exploit CVE-2008-0166 by guessing a key that was not identified by this tool.

Record
EUVD-2008-2282
Updated
2026-11-03
GitHub AdvisoriesGHSA-9c93-c5gr-q8j9 No score

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys...

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys lines that contain options, which makes it easier for remote attackers to exploit CVE-2008-0166 by guessing a key that was not identified by this tool.

Record
GHSA-9c93-c5gr-q8j9
Updated
2026-11-02
OSV No score

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys lines that contain options, which makes it easier for remote attackers to exploit CVE-2008-0166 by guessing a key that was not identified by this tool.

Record
CVE-2008-2285
Updated
2026-11-02
OSVDEBIAN-CVE-2008-2285 No score

The ssh-vulnkey tool on Ubuntu Linux 7.04, 7.10, and 8.04 LTS does not recognize authorized_keys lines that contain options, which makes it easier for remote attackers to exploit CVE-2008-0166 by guessing a key that was not identified by this tool.

Record
DEBIAN-CVE-2008-2285
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openssh
Debian:12
before 1:4.7p1-10
1:4.7p1-10
openssh
Debian:13
before 1:4.7p1-10
1:4.7p1-10
openssh
Debian:14
before 1:4.7p1-10
1:4.7p1-10
openssh
Debian:4.0
before 1:4.3p2-9etch2, plus listed versions
1:4.3p2-91:4.3p2-9etch1
1:4.3p2-9etch2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02aliases
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open