Every CVE Search/ Get API key

CVE-2008-2316

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow...

7.5 HighFix available

CVE-2008-2316 is a high vulnerability (CVSS 7.5) in Python, published August 1, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.09%, the 90th percentile. Fixed in python2.4 2.4.4-3+etch3.

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."

Exploit likelihood

4.09%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."

Record
CVE-2008-2316
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."

Record
CVE-2008-2316
Updated
2026-11-02
EUVDEUVD-2008-2312 No score

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."

Record
EUVD-2008-2312
Updated
2026-11-03
GitHub AdvisoriesGHSA-482h-xg25-ghqh No score

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow...

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."

Record
GHSA-482h-xg25-ghqh
Updated
2026-11-02
OSVAZL-109569 No score

CVE-2008-2316 affecting package python-py 1.11.0-1

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."

Record
AZL-109569
Updated
2026-11-02
OSVopenSUSE-SU-2024:11202-1 No score

python-2.7.18-8.1 on GA media

These are all security issues fixed in the python-2.7.18-8.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11202-1
Updated
2026-11-02
OSVPSF-2008-5 No score

Multiple integer overflows (Apple)

Integer overflow in _hashopenssl.c in the hashlib module in Python 2.5.2 and earlier might allow context-dependent attackers to defeat cryptographic digests, related to "partial hashlib hashing of data exceeding 4GB."

Record
PSF-2008-5
Updated
2026-11-02
OSVSUSE-SU-2020:0234-1 No score

Security update for python

This update for python fixes the following issues:

Updated to version 2.7.17 to unify packages among openSUSE:Factory and SLE versions (bsc#1159035).

Record
SUSE-SU-2020:0234-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
python-py
Azure Linux:3
through 1.11.0-1 None known
python2.4
Debian:4.0
before 2.4.4-3+etch3, plus listed versions
2.4.4-32.4.4-3+etch12.4.4-3+etch2
2.4.4-3+etch3
python2.5
Debian:4.0
before 2.5-5+etch2, plus listed versions
2.5-52.5-5+etch1
2.5-5+etch2
python2.4
Debian:5.0
before 2.4.6-1+lenny1, plus listed versions
2.4.6-1
2.4.6-1+lenny1
python2.5
Debian:5.0
before 2.5.2-15+lenny1, plus listed versions
2.5.2-15
2.5.2-15+lenny1
python2.5
Debian:5.0
before 2.5.2-6+lenny1
2.5.2-6+lenny1
python
SUSE:Linux Enterprise Module for Basesystem 15
before 2.7.17-7.32.2
2.7.17-7.32.2
python-base
SUSE:Linux Enterprise Module for Basesystem 15
before 2.7.17-7.32.1
2.7.17-7.32.1
python
SUSE:Linux Enterprise Module for Basesystem 15 SP1
before 2.7.17-7.32.2
2.7.17-7.32.2
python-base
SUSE:Linux Enterprise Module for Basesystem 15 SP1
before 2.7.17-7.32.1
2.7.17-7.32.1
Show 5 moreShow less
Affected packages
PackageAffectedFixed
python
SUSE:Linux Enterprise Module for Desktop Applications 15
before 2.7.17-7.32.2
2.7.17-7.32.2
python
SUSE:Linux Enterprise Module for Desktop Applications 15 SP1
before 2.7.17-7.32.2
2.7.17-7.32.2
python
SUSE:Linux Enterprise Module for Python 2 15 SP1
before 2.7.17-7.32.2
2.7.17-7.32.2
python-base
SUSE:Linux Enterprise Module for Python 2 15 SP1
before 2.7.17-7.32.1
2.7.17-7.32.1
python
openSUSE:Tumbleweed
before 2.7.18-8.1
2.7.18-8.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 152 moreShow less
MoveEnter Open