Every CVE Search/ Get API key

CVE-2008-2667

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0...

5.1 MediumFix available

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

Exploit likelihood

1.53%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

Record
CVE-2008-2667
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

Record
CVE-2008-2667
Updated
2026-11-02
EUVDEUVD-2008-2662 No score

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

Record
EUVD-2008-2662
Updated
2026-11-03
GitHub AdvisoriesGHSA-3r5f-vjfp-r32c No score

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0...

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

Record
GHSA-3r5f-vjfp-r32c
Weakness
CWE-89
Updated
2026-11-02
OSV No score

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

Record
CVE-2008-2667
Updated
2026-11-02
OSVDEBIAN-CVE-2008-2667 No score

SQL injection vulnerability in the Courier Authentication Library (aka courier-authlib) before 0.60.6 on SUSE openSUSE 10.3 and 11.0, and other platforms, when MySQL and a non-Latin character set are used, allows remote attackers to execute arbitrary SQL commands via the username and unspecified other vectors.

Record
DEBIAN-CVE-2008-2667
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
courier-authlib
Debian:12
before 0.60.1-2.1
0.60.1-2.1
courier-authlib
Debian:13
before 0.60.1-2.1
0.60.1-2.1
courier-authlib
Debian:14
before 0.60.1-2.1
0.60.1-2.1
courier-authlib
Debian:4.0
From an advisory covering 2 CVEs
before 0.58-4+etch2, plus listed versions
0.58-4
0.58-4+etch2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-2667 is a medium vulnerability (CVSS 5.1) in Courier-mta Courtier-authlib, published July 7, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.53%, the 74th percentile. Fixed in courier-authlib 0.60.1-2.1.

References

Show 7 moreShow less
MoveEnter Open