CVE-2008-2829
php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow...
CVE-2008-2829 is a medium vulnerability (CVSS 5.0) in Php, published June 23, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.27%, the 92nd percentile. Fixed in php5 5.2.5-3+lenny2.
php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.
Exploit likelihood
What each source reports
NVD Score used
5.0
php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.
- Record
CVE-2008-2829- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.
- Record
CVE-2008-2829- Updated
- 2026-11-02
EUVDEUVD-2008-2822 No score
php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.
- Record
EUVD-2008-2822- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j7wp-2pxv-m6g9 No score
php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow...
php_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.
- Record
GHSA-j7wp-2pxv-m6g9- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php5Debian:5.0 |
before 5.2.5-3+lenny2 | 5.2.5-3+lenny2 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
openwall.com/lists/oss-security/2008/06/24/2
securityfocus.com/bid/29829
secunia.com/advisories/32746
marc.info?l=bugtraq&m=125631037611762&w=2
support.apple.com/kb/HT3549
security.gentoo.org/glsa/glsa-200811-05.xml
Show 24 moreShow less
exchange.xforce.ibmcloud.com/vulnerabilities/43357
marc.info?l=bugtraq&m=124654546101607&w=2
redhat.com/archives/fedora-package-announce/2009-May/msg01451.html
securityfocus.com/archive/1/501376/100/0/threaded
wiki.rpath.com/Advisories:rPSA-2009-0035
mandriva.com/security/advisories?name=MDVSA-2008:128
secunia.com/advisories/35074
ubuntu.com/usn/usn-628-1
lists.apple.com/archives/security-announce/2009/May/msg00002.html
lists.opensuse.org/opensuse-security-announce/2008-12/msg00002.html
openwall.com/lists/oss-security/2008/06/19/6
secunia.com/advisories/31200
osvdb.org/46641
redhat.com/archives/fedora-package-announce/2009-May/msg01465.html
us-cert.gov/cas/techalerts/TA09-133A.html
vupen.com/english/advisories/2009/1297
bugs.php.net/bug.php?id=42862
mandriva.com/security/advisories?name=MDVSA-2008:126
secunia.com/advisories/35306
mandriva.com/security/advisories?name=MDVSA-2008:127
bugs.gentoo.org/show_bug.cgi?id=221969
secunia.com/advisories/35650
nvd.nist.gov/vuln/detail/CVE-2008-2829
github.com/advisories/GHSA-j7wp-2pxv-m6g9