CVE-2008-2992
Stack-based buffer overflow in Adobe Acrobat and Reader 8.1.2 and earlier allows remote attackers...
Stack-based buffer overflow in Adobe Acrobat and Reader 8.1.2 and earlier allows remote attackers to execute arbitrary code via a PDF file that calls the util.printf JavaScript function with a crafted format string argument, a related issue to CVE-2008-1104.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Stack-based buffer overflow in Adobe Acrobat and Reader 8.1.2 and earlier allows remote attackers to execute arbitrary code via a PDF file that calls the util.printf JavaScript function with a crafted format string argument, a related issue to CVE-2008-1104.
- Record
CVE-2008-2992- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List
7.8
Stack-based buffer overflow in Adobe Acrobat and Reader 8.1.2 and earlier allows remote attackers to execute arbitrary code via a PDF file that calls the util.printf JavaScript function with a crafted format string argument, a related issue to CVE-2008-1104.
- Record
CVE-2008-2992- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2008-2982
7.8
Stack-based buffer overflow in Adobe Acrobat and Reader 8.1.2 and earlier allows remote attackers to execute arbitrary code via a PDF file that calls the util.printf JavaScript function with a crafted format string argument, a related issue to CVE-2008-1104.
- Record
EUVD-2008-2982- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-c6vf-qwc3-92qf
7.8
Stack-based buffer overflow in Adobe Acrobat and Reader 8.1.2 and earlier allows remote attackers...
Stack-based buffer overflow in Adobe Acrobat and Reader 8.1.2 and earlier allows remote attackers to execute arbitrary code via a PDF file that calls the util.printf JavaScript function with a crafted format string argument, a related issue to CVE-2008-1104.
- Record
GHSA-c6vf-qwc3-92qf- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-787
- Updated
- 2026-11-02
CISA KEV No score
Adobe Reader and Acrobat Input Validation Vulnerability
Adobe Acrobat and Reader contain an input validation issue in a JavaScript method that could potentially lead to remote code execution.
- Record
CVE-2008-2992- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
acroreadRed Hat:rhel_extras:3 |
before 0:8.1.3-1 | 0:8.1.3-1 |
acroread-pluginRed Hat:rhel_extras:3 |
before 0:8.1.3-1 | 0:8.1.3-1 |
acroreadRed Hat:rhel_extras:4 |
before 0:8.1.3-1.el4 | 0:8.1.3-1.el4 |
acroread-pluginRed Hat:rhel_extras:4 |
before 0:8.1.3-1.el4 | 0:8.1.3-1.el4 |
acroreadRed Hat:rhel_extras:5::client |
before 0:8.1.3-1.el5 | 0:8.1.3-1.el5 |
acroread-pluginRed Hat:rhel_extras:5::client |
before 0:8.1.3-1.el5 | 0:8.1.3-1.el5 |
acroreadRed Hat:rhel_extras:5::server |
before 0:8.1.3-1.el5 | 0:8.1.3-1.el5 |
acroread-pluginRed Hat:rhel_extras:5::server |
before 0:8.1.3-1.el5 | 0:8.1.3-1.el5 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | Adobe util.printf() Buffer Overflow | 2008-02-08 |
| Metasploit | Adobe util.printf() Buffer Overflow | 2008-02-08 |
| Exploit-DB | Adobe Reader - 'util.printf()' JavaScript Function Stack Overflow (1) | 2008-11-05 |
| Exploit-DB | Adobe Reader - 'util.printf()' JavaScript Function Stack Overflow (2) | 2008-11-05 |
| Exploit-DB | Adobe - 'util.printf()' Local Buffer Overflow (Metasploit) (1) | 2010-05-03 |
| Exploit-DB | Adobe - 'util.printf()' Local Buffer Overflow (Metasploit) (2) | 2010-09-25 |
| PoC in GitHub | Jonas-Holmberg/CVE-2008-2992 | 2026-04-15 |
History
| Recorded | Changed | Sources |
|---|---|---|
| exploitation, exploits | ||
| first indexed | CVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-2992 is a high vulnerability (CVSS 7.8) in Adobe Acrobat, published November 4, 2008. CISA lists it as known to be exploited, since March 3, 2022. EUVD reports exploitation since March 3, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 99.8%, the 99th percentile. Fixed in acroread 0:8.1.3-1.
References
securityfocus.com/bid/30035
secunia.com/advisories/32700
support.nortel.com/go/main.jsp?cscat=BLTNDETAIL&id=909609
securityfocus.com/archive/1/498027/100/0/threaded
secunia.com/secunia_research/2008-14
securityfocus.com/bid/32091
Show 59 moreShow less
osvdb.org/49520
secunia.com/advisories/35163
download.oracle.com/sunalerts/1019937.1.html
secunia.com/advisories/32872
exploit-db.com/exploits/7006
securityreason.com/securityalert/4549
coresecurity.com/content/adobe-reader-buffer-overflow
zerodayinitiative.com/advisories/ZDI-08-072
adobe.com/support/security/bulletins/apsb08-19.html
securityfocus.com/archive/1/498055/100/0/threaded
exploit-db.com/exploits/6994
vupen.com/english/advisories/2009/0098
secunia.com/advisories/29773
us-cert.gov/cas/techalerts/TA08-309A.html
securitytracker.com/id?1021140
securityfocus.com/archive/1/498032/100/0/threaded
vupen.com/english/advisories/2008/3001
lists.opensuse.org/opensuse-security-announce/2008-11/msg00002.html
redhat.com/support/errata/RHSA-2008-0974.html
kb.cert.org/vuls/id/593409
support.nortel.com/go/main.jsp?cscat=BLTNDETAIL&id=800801
cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2008-2992
nvd.nist.gov/vuln/detail/CVE-2008-2992
github.com/advisories/GHSA-c6vf-qwc3-92qf
access.redhat.com/errata/RHSA-2008:0974
redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=450078
bugzilla.redhat.com/show_bug.cgi?id=469875
bugzilla.redhat.com/show_bug.cgi?id=469876
bugzilla.redhat.com/show_bug.cgi?id=469877
bugzilla.redhat.com/show_bug.cgi?id=469880
bugzilla.redhat.com/show_bug.cgi?id=469882
bugzilla.redhat.com/show_bug.cgi?id=469923
security.access.redhat.com/data/csaf/v2/advisories/2008/rhsa-2008_0974.json
access.redhat.com/security/cve/CVE-2008-2549
cve.org/CVERecord?id=CVE-2008-2549
nvd.nist.gov/vuln/detail/CVE-2008-2549
access.redhat.com/security/cve/CVE-2008-2992
cve.org/CVERecord?id=CVE-2008-2992
cisa.gov/known-exploited-vulnerabilities-catalog
access.redhat.com/security/cve/CVE-2008-4812
cve.org/CVERecord?id=CVE-2008-4812
nvd.nist.gov/vuln/detail/CVE-2008-4812
access.redhat.com/security/cve/CVE-2008-4813
cve.org/CVERecord?id=CVE-2008-4813
nvd.nist.gov/vuln/detail/CVE-2008-4813
access.redhat.com/security/cve/CVE-2008-4814
cve.org/CVERecord?id=CVE-2008-4814
nvd.nist.gov/vuln/detail/CVE-2008-4814
access.redhat.com/security/cve/CVE-2008-4815
cve.org/CVERecord?id=CVE-2008-4815
nvd.nist.gov/vuln/detail/CVE-2008-4815
access.redhat.com/security/cve/CVE-2008-4817
cve.org/CVERecord?id=CVE-2008-4817
nvd.nist.gov/vuln/detail/CVE-2008-4817
access.redhat.com/security/cve/CVE-2009-0927
bugzilla.redhat.com/show_bug.cgi?id=1618340
cve.org/CVERecord?id=CVE-2009-0927
nvd.nist.gov/vuln/detail/CVE-2009-0927