Every CVE Search/ Get API key

CVE-2008-3740

Cross-site scripting (XSS) vulnerability in the output filter in Drupal 5.x before 5.10 and 6.x...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the output filter in Drupal 5.x before 5.10 and 6.x before 6.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Exploit likelihood

1.55%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the output filter in Drupal 5.x before 5.10 and 6.x before 6.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2008-3740
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the output filter in Drupal 5.x before 5.10 and 6.x before 6.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2008-3740
Updated
2026-11-02
EUVDEUVD-2008-3726 No score

Cross-site scripting (XSS) vulnerability in the output filter in Drupal 5.x before 5.10 and 6.x before 6.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2008-3726
Updated
2026-11-03
GitHub AdvisoriesGHSA-h6w3-vjv8-9p4h No score

Cross-site scripting (XSS) vulnerability in the output filter in Drupal 5.x before 5.10 and 6.x...

Cross-site scripting (XSS) vulnerability in the output filter in Drupal 5.x before 5.10 and 6.x before 6.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-h6w3-vjv8-9p4h
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal5
Debian:5.0
before 5.9-1.1+lenny1, plus listed versions
5.1-15.1-25.1-35.2-15.2-2
Show 10 moreShow less
5.2-35.3-15.5-15.6-15.6-25.7-15.7-25.8-15.9-15.9-1~lenny1
5.9-1.1+lenny1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-3740 is a medium vulnerability (CVSS 4.3) in Drupal, published August 17, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.55%, the 75th percentile. Fixed in drupal5 5.9-1.1+lenny1.

References

Show 5 moreShow less
MoveEnter Open