Every CVE Search/ Get API key

CVE-2008-3834

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote...

2.1 LowPublic exploitFix available

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Exploit likelihood

4.58%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Record
CVE-2008-3834
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Record
CVE-2008-3834
Updated
2026-11-02
EUVDEUVD-2008-3820 No score

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Record
EUVD-2008-3820
Updated
2026-11-03
GitHub AdvisoriesGHSA-mwh5-h5c7-v5xw No score

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote...

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Record
GHSA-mwh5-h5c7-v5xw
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Record
CVE-2008-3834
Updated
2026-11-02
OSVDEBIAN-CVE-2008-3834 No score

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Record
DEBIAN-CVE-2008-3834
Updated
2026-11-02
OSVopenSUSE-SU-2024:10711-1 No score

dbus-1-1.12.20-5.5 on GA media

These are all security issues fixed in the dbus-1-1.12.20-5.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10711-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dbus
Debian:12
before 1.2.1-4
1.2.1-4
dbus
Debian:13
before 1.2.1-4
1.2.1-4
dbus
Debian:14
before 1.2.1-4
1.2.1-4
dbus
Debian:4.0
before 1.0.2-1+etch2, plus listed versions
1.0.2-11.0.2-1+etch1
1.0.2-1+etch2
dbus
Red Hat:enterprise_linux:5::client_workstation
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus
Red Hat:enterprise_linux:5::client
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-x11
Red Hat:enterprise_linux:5::client
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
Show 5 moreShow less
Affected packages
PackageAffectedFixed
dbus
Red Hat:enterprise_linux:5::server
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-devel
Red Hat:enterprise_linux:5::server
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-x11
Red Hat:enterprise_linux:5::server
before 0:1.0.0-7.el5_2.1
0:1.0.0-7.el5_2.1
dbus-1
openSUSE:Tumbleweed
From an advisory covering 6 CVEs
before 1.12.20-5.5
1.12.20-5.5

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBD-Bus Daemon < 1.2.4 - 'libdbus' Denial of Service2009-01-19

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-3834 is a low vulnerability (CVSS 2.1) in Freedesktop Dbus, published October 7, 2008. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.58%, the 91st percentile. Fixed in dbus 1.2.1-4.

References

Show 31 moreShow less
MoveEnter Open