Every CVE Search/ Get API key

CVE-2008-3972

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the...

6.6 MediumFix available

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

Exploit likelihood

0.37%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.6

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

Record
CVE-2008-3972
CVSS 2.0
6.6 MediumAV:L/AC:L/Au:N/C:N/I:C/A:C
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

Record
CVE-2008-3972
Updated
2026-11-02
EUVDEUVD-2008-3957 No score

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

Record
EUVD-2008-3957
Updated
2026-11-03
GitHub AdvisoriesGHSA-445p-3crg-24jx No score

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the...

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

Record
GHSA-445p-3crg-24jx
Updated
2026-11-02
OSV No score

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

Record
CVE-2008-3972
Updated
2026-11-02
OSVDEBIAN-CVE-2008-3972 No score

pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card unless the card's label matches the "OpenSC" string, which might allow physically proximate attackers to exploit vulnerabilities that the card owner expected were patched, as demonstrated by exploitation of CVE-2008-2235.

Record
DEBIAN-CVE-2008-3972
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opensc
Debian:12
before 0.11.4-5
0.11.4-5
opensc
Debian:13
before 0.11.4-5
0.11.4-5
opensc
Debian:14
before 0.11.4-5
0.11.4-5
opensc
Debian:4.0
From an advisory covering 2 CVEs
before 0.11.1-2etch2, plus listed versions
0.11.1-20.11.1-2etch1
0.11.1-2etch2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-3972 is a medium vulnerability (CVSS 6.6) in Opensc-project Opensc, published August 4, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 30th percentile. Fixed in opensc 0.11.4-5.

References

Show 4 moreShow less
MoveEnter Open