Every CVE Search/ Get API key

CVE-2008-4094

Rails ActiveRecord gem vulnerable to SQL injection

7.5 HighFix available

CVE-2008-4094 is a high vulnerability (CVSS 7.5) in Rubyonrails Rails, published September 30, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.03%, the 87th percentile. Fixed in activerecord 2.1.1.

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Exploit likelihood

3.03%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Record
CVE-2008-4094
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Record
CVE-2008-4094
Updated
2026-11-02
EUVDEUVD-2017-0329 No score

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Record
EUVD-2017-0329
Updated
2026-11-03
GitHub AdvisoriesGHSA-xf96-32q2-9rw2 No score

Rails ActiveRecord gem vulnerable to SQL injection

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Record
GHSA-xf96-32q2-9rw2
Weakness
CWE-89
Updated
2026-11-02
OSV No score

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Record
CVE-2008-4094
Updated
2026-11-02
OSVDEBIAN-CVE-2008-4094 No score

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Record
DEBIAN-CVE-2008-4094
Updated
2026-11-02
OSVGHSA-xf96-32q2-9rw2 No score

Rails ActiveRecord gem vulnerable to SQL injection

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

Record
GHSA-xf96-32q2-9rw2
Weakness
CWE-89
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
activerecord
RubyGems
before 2.1.1
2.1.1
rails
Debian:12
before 2.1.0-1
2.1.0-1
rails
Debian:13
before 2.1.0-1
2.1.0-1
rails
Debian:14
before 2.1.0-1
2.1.0-1
activerecord
RubyGems
before 2.1.1, plus listed versions
1.0.01.1.01.10.01.10.11.11.0
Show 34 moreShow less
1.11.11.12.11.12.21.13.01.13.11.13.21.14.01.14.11.14.21.14.31.14.41.15.01.15.11.15.21.15.31.15.41.15.51.15.61.2.01.3.01.4.01.5.01.5.11.6.01.7.01.8.01.9.01.9.12.0.02.0.12.0.22.0.42.0.52.1.0
2.1.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 25 moreShow less
MoveEnter Open