CVE-2008-4776
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact...
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
Exploit likelihood
What each source reports
NVD Score used
4.3
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
- Record
CVE-2008-4776- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
- Record
CVE-2008-4776- Updated
- 2026-11-02
EUVDEUVD-2008-4756 No score
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
- Record
EUVD-2008-4756- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3p9w-wq67-w93f No score
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact...
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
- Record
GHSA-3p9w-wq67-w93f- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
- Record
CVE-2008-4776- Updated
- 2026-11-02
OSVDEBIAN-CVE-2008-4776 No score
libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read.
- Record
DEBIAN-CVE-2008-4776- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10940-1 No score
libgadu-devel-1.12.2-2.11 on GA media
These are all security issues fixed in the libgadu-devel-1.12.2-2.11 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10940-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libgaduDebian:12 |
before 1:1.8.0+r592-3 | 1:1.8.0+r592-3 |
libgaduDebian:13 |
before 1:1.8.0+r592-3 | 1:1.8.0+r592-3 |
libgaduDebian:14 |
before 1:1.8.0+r592-3 | 1:1.8.0+r592-3 |
ekgDebian:4.0 |
before 1:1.7~rc2-1etch2, plus listed versions 1:1.7~rc2-11:1.7~rc2-1etch1 |
1:1.7~rc2-1etch2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-4776 is a medium vulnerability (CVSS 4.3) in Wojtek Kaniewsk Libgadu, published October 28, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.26%, the 69th percentile. Fixed in libgadu 1:1.8.0+r592-3.