Every CVE Search/ Get API key

CVE-2008-4793

Drupal Node Validation Bypass in the node module API

7.5 HighFix available

The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.

Exploit likelihood

2.21%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.

Record
CVE-2008-4793
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.

Record
CVE-2008-4793
Updated
2026-11-02
EUVDEUVD-2022-4766 No score

The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.

Record
EUVD-2022-4766
Updated
2026-11-03
GitHub AdvisoriesGHSA-ph2j-5hxq-gxrr No score

Drupal Node Validation Bypass in the node module API

The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.

Record
GHSA-ph2j-5hxq-gxrr
Weakness
CWE-284
Updated
2026-11-02
OSVGHSA-ph2j-5hxq-gxrr No score

Drupal Node Validation Bypass in the node module API

The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.

Record
GHSA-ph2j-5hxq-gxrr
Weakness
CWE-284
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/drupal
Packagist
5.0 up to 5.11
5.11

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-4793 is a high vulnerability (CVSS 7.5) in Drupal, published October 29, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in drupal/drupal 5.11.

References

MoveEnter Open