Every CVE Search/ Get API key

CVE-2008-4811

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in Smarty 2.6.20 r2797 and...

7.5 HighFix available

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in Smarty 2.6.20 r2797 and earlier allows remote attackers to execute arbitrary PHP code via vectors related to templates and a \ (backslash) before a dollar-sign character.

Exploit likelihood

1.64%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in Smarty 2.6.20 r2797 and earlier allows remote attackers to execute arbitrary PHP code via vectors related to templates and a \ (backslash) before a dollar-sign character.

Record
CVE-2008-4811
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in Smarty 2.6.20 r2797 and earlier allows remote attackers to execute arbitrary PHP code via vectors related to templates and a \ (backslash) before a dollar-sign character.

Record
CVE-2008-4811
Updated
2026-11-02
EUVDEUVD-2008-4790 No score

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in Smarty 2.6.20 r2797 and earlier allows remote attackers to execute arbitrary PHP code via vectors related to templates and a \ (backslash) before a dollar-sign character.

Record
EUVD-2008-4790
Updated
2026-11-03
GitHub AdvisoriesGHSA-w343-xc9v-r5ww No score

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in Smarty 2.6.20 r2797 and...

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in Smarty 2.6.20 r2797 and earlier allows remote attackers to execute arbitrary PHP code via vectors related to templates and a \ (backslash) before a dollar-sign character.

Record
GHSA-w343-xc9v-r5ww
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle
Debian:4.0
before 1.6.3-2+etch1, plus listed versions
1.6.3-2
1.6.3-2+etch1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-4811 is a high vulnerability (CVSS 7.5) in Smarty, published October 31, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.64%, the 76th percentile. Fixed in moodle 1.6.3-2+etch1.

References

MoveEnter Open