CVE-2008-5153
Moodle vulnerable to symlink attack
spell-check-logic.cgi in Moodle 1.8.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
Exploit likelihood
What each source reports
NVD Score used
6.9
spell-check-logic.cgi in Moodle 1.8.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
- Record
CVE-2008-5153- CVSS 2.0
- 6.9 Medium
AV:L/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-59
- Updated
- 2026-11-02
CVE List No score
spell-check-logic.cgi in Moodle 1.8.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
- Record
CVE-2008-5153- Updated
- 2026-11-02
EUVDEUVD-2022-5741 No score
spell-check-logic.cgi in Moodle 1.8.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
- Record
EUVD-2022-5741- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x7r4-26m9-hmgq No score
Moodle vulnerable to symlink attack
spell-check-logic.cgi in Moodle 1.9 before 1.9.4, 1.8 before 1.8.8, 1.7 before 1.7.7 and 1.6 before 1.6.9 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
- Record
GHSA-x7r4-26m9-hmgq- Weakness
- CWE-59
- Updated
- 2026-11-02
OSVGHSA-x7r4-26m9-hmgq No score
Moodle vulnerable to symlink attack
spell-check-logic.cgi in Moodle 1.9 before 1.9.4, 1.8 before 1.8.8, 1.7 before 1.7.7 and 1.6 before 1.6.9 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
- Record
GHSA-x7r4-26m9-hmgq- Weakness
- CWE-59
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
1.9.0 up to 1.9.4 | 1.9.4 |
moodle/moodlePackagist |
1.8.0 up to 1.8.8 | 1.8.8 |
moodle/moodlePackagist |
1.7.0 up to 1.7.7 | 1.7.7 |
moodle/moodlePackagist |
1.6.0 up to 1.6.9 | 1.6.9 |
moodleDebian:4.0 |
before 1.6.3-2+etch2, plus listed versions 1.6.3-21.6.3-2+etch1 |
1.6.3-2+etch2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2008-5153 is a medium vulnerability (CVSS 6.9) in Moodle, published November 18, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 33rd percentile. Fixed in moodle/moodle 1.9.4.
References
securityfocus.com/bid/32402
lists.debian.org/debian-devel/2008/08/msg00347.html
uvw.ru/report.sid.txt
secunia.com/advisories/33955
debian.org/security/2009/dsa-1724
exchange.xforce.ibmcloud.com/vulnerabilities/46708
Show 6 moreShow less
nvd.nist.gov/vuln/detail/CVE-2008-5153
web.archive.org/web/20090821033319/http://secunia.com/advisories/33955
web.archive.org/web/20110511083352/http://uvw.ru/report.sid.txt
web.archive.org/web/20141121115305/http://www.securityfocus.com/bid/32402
github.com/advisories/GHSA-x7r4-26m9-hmgq
github.com/moodle/moodle