Every CVE Search/ Get API key

CVE-2008-5587

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when...

4.3 MediumPublic exploitFix available

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Exploit likelihood

12.9%Up 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Record
CVE-2008-5587
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Record
CVE-2008-5587
Updated
2026-11-02
EUVDEUVD-2008-5562 No score

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Record
EUVD-2008-5562
Updated
2026-11-03
GitHub AdvisoriesGHSA-v758-3cg3-fww7 No score

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when...

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Record
GHSA-v758-3cg3-fww7
Weakness
CWE-22
Updated
2026-11-02
OSV No score

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Record
CVE-2008-5587
Updated
2026-11-02
OSVDEBIAN-CVE-2008-5587 No score

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

Record
DEBIAN-CVE-2008-5587
Updated
2026-11-02
OSVopenSUSE-SU-2024:10035-1 No score

phpPgAdmin-5.1-5.1 on GA media

These are all security issues fixed in the phpPgAdmin-5.1-5.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10035-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phppgadmin
Debian:13
before 4.2.1-1.1
4.2.1-1.1
phppgadmin
Debian:14
before 4.2.1-1.1
4.2.1-1.1
phppgadmin
Debian:4.0
before 4.0.1-3.1etch1, plus listed versions
4.0.1-3.1
4.0.1-3.1etch1
phpPgAdmin
openSUSE:Tumbleweed
before 5.1-5.1
5.1-5.1

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Nuclei, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-5587 is a medium vulnerability (CVSS 4.3) in Phppgadmin, published December 16, 2008. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 12.9%, the 96th percentile. Fixed in phppgadmin 4.2.1-1.1.

References

Show 9 moreShow less
MoveEnter Open