Every CVE Search/ Get API key

CVE-2008-5902

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and...

7.5 HighFix available

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request.

Exploit likelihood

3.38%Down 3.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request.

Record
CVE-2008-5902
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request.

Record
CVE-2008-5902
Updated
2026-11-02
EUVDEUVD-2008-5872 No score

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request.

Record
EUVD-2008-5872
Updated
2026-11-03
GitHub AdvisoriesGHSA-j9gf-75xm-4w77 No score

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and...

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request.

Record
GHSA-j9gf-75xm-4w77
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request.

Record
CVE-2008-5902
Updated
2026-11-02
OSVDEBIAN-CVE-2008-5902 No score

Buffer overflow in the xrdp_bitmap_invalidate function in xrdp/xrdp_bitmap.c in xrdp 0.4.1 and earlier allows remote attackers to execute arbitrary code via a crafted request.

Record
DEBIAN-CVE-2008-5902
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xrdp
Debian:12
before 0.4.0~dfsg-9
0.4.0~dfsg-9
xrdp
Debian:13
before 0.4.0~dfsg-9
0.4.0~dfsg-9
xrdp
Debian:14
before 0.4.0~dfsg-9
0.4.0~dfsg-9

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-5902 is a high vulnerability (CVSS 7.5) in Xrdp, published January 15, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.38%, the 88th percentile. Fixed in xrdp 0.4.0~dfsg-9.

References

MoveEnter Open