CVE-2008-6189
SQL injection vulnerability in GForge 4.5.19 allows remote attackers to execute arbitrary SQL...
CVE-2008-6189 is a high vulnerability (CVSS 7.5) in Gforge, published January 9, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.32%, the 83rd percentile. Fixed in gforge 4.5.14-22etch10.
SQL injection vulnerability in GForge 4.5.19 allows remote attackers to execute arbitrary SQL commands via the offset parameter to (1) new/index.php, (2) news/index.php, and (3) top/topusers.php, which is not properly handled in database-pgsql.php.
Exploit likelihood
What each source reports
NVD Score used
7.5
SQL injection vulnerability in GForge 4.5.19 allows remote attackers to execute arbitrary SQL commands via the offset parameter to (1) new/index.php, (2) news/index.php, and (3) top/topusers.php, which is not properly handled in database-pgsql.php.
- Record
CVE-2008-6189- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
SQL injection vulnerability in GForge 4.5.19 allows remote attackers to execute arbitrary SQL commands via the offset parameter to (1) new/index.php, (2) news/index.php, and (3) top/topusers.php, which is not properly handled in database-pgsql.php.
- Record
CVE-2008-6189- Updated
- 2026-11-02
EUVDEUVD-2008-6159 No score
SQL injection vulnerability in GForge 4.5.19 allows remote attackers to execute arbitrary SQL commands via the offset parameter to (1) new/index.php, (2) news/index.php, and (3) top/topusers.php, which is not properly handled in database-pgsql.php.
- Record
EUVD-2008-6159- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6v3f-rwg9-w274 No score
SQL injection vulnerability in GForge 4.5.19 allows remote attackers to execute arbitrary SQL...
SQL injection vulnerability in GForge 4.5.19 allows remote attackers to execute arbitrary SQL commands via the offset parameter to (1) new/index.php, (2) news/index.php, and (3) top/topusers.php, which is not properly handled in database-pgsql.php.
- Record
GHSA-6v3f-rwg9-w274- Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gforgeDebian:4.0 |
before 4.5.14-22etch10, plus listed versions 4.5.14-224.5.14-22etch14.5.14-22etch24.5.14-22etch34.5.14-22etch4 Show 5 moreShow less4.5.14-22etch54.5.14-22etch64.5.14-22etch74.5.14-22etch84.5.14-22etch9 |
4.5.14-22etch10 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | GForge 4.5.19 - Multiple SQL Injections | 2008-10-09 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |