Every CVE Search/ Get API key

CVE-2008-7248

Improper Input Validation in actionpack

6.8 MediumPublic exploitFix available

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Exploit likelihood

8.08%Down 2.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Record
CVE-2008-7248
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Record
CVE-2008-7248
Updated
2026-11-02
EUVDEUVD-2017-0192 No score

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Record
EUVD-2017-0192
Updated
2026-11-03
GitHub AdvisoriesGHSA-8fqx-7pv4-3jwm No score

Improper Input Validation in actionpack

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Record
GHSA-8fqx-7pv4-3jwm
Weakness
CWE-20
Updated
2026-11-02
OSV No score

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Record
CVE-2008-7248
Updated
2026-11-02
OSVDEBIAN-CVE-2008-7248 No score

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Record
DEBIAN-CVE-2008-7248
Updated
2026-11-02
OSVGHSA-8fqx-7pv4-3jwm No score

Improper Input Validation in actionpack

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Record
GHSA-8fqx-7pv4-3jwm
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
actionpack
RubyGems
2.1.0 up to 2.1.3
2.1.3
actionpack
RubyGems
2.2.0 up to 2.2.2
2.2.2
rails
Debian:12
before 2.2.3-1
2.2.3-1
rails
Debian:13
before 2.2.3-1
2.2.3-1
rails
Debian:14
before 2.2.3-1
2.2.3-1
actionpack
RubyGems
2.1.0 up to 2.1.3, plus listed versions
2.1.12.1.2
2.1.3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBRuby on Rails 2.3.5 - 'protect_from_forgery' Cross-Site Request Forgery2009-12-14

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-7248 is a medium vulnerability (CVSS 6.8) in Rubyonrails Rails, published December 16, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.08%, the 94th percentile. Fixed in actionpack 2.1.3.

References

Show 13 moreShow less
MoveEnter Open