Every CVE Search/ Get API key

CVE-2009-0026

Apache Jackrabbit contains Cross-site Scripting

4.3 MediumPublic exploitFix available

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.

Exploit likelihood

26.8%Up 16.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.

Record
CVE-2009-0026
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.

Record
CVE-2009-0026
Updated
2026-11-02
EUVDEUVD-2022-2785 No score

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.

Record
EUVD-2022-2785
Updated
2026-11-03
GitHub AdvisoriesGHSA-6fxv-38xc-h866 No score

Apache Jackrabbit contains Cross-site Scripting

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.

Record
GHSA-6fxv-38xc-h866
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-6fxv-38xc-h866 No score

Apache Jackrabbit contains Cross-site Scripting

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jackrabbit before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the q parameter to (1) search.jsp or (2) swr.jsp.

Record
GHSA-6fxv-38xc-h866
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.jackrabbit:jackrabbit
Maven
before 1.5.2
1.5.2
org.apache.jackrabbit:jackrabbit
Maven
before 1.5.2, plus listed versions
1.2.11.2.21.2.31.31.3.11.3.31.41.5.0
1.5.2

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0026 is a medium vulnerability (CVSS 4.3) in Apache Jackrabbit, published January 21, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 26.8%, the 98th percentile. Fixed in org.apache.jackrabbit:jackrabbit 1.5.2.

References

Show 8 moreShow less
MoveEnter Open