CVE-2009-0035
alsa-utils 1.0.19 and later versions allows local users to overwrite arbitrary files via a...
alsa-utils 1.0.19 and later versions allows local users to overwrite arbitrary files via a symlink attack via the /usr/bin/alsa-info and /usr/bin/alsa-info.sh scripts.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.5
alsa-utils 1.0.19 and later versions allows local users to overwrite arbitrary files via a symlink attack via the /usr/bin/alsa-info and /usr/bin/alsa-info.sh scripts.
- Record
CVE-2009-0035- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 3.6 Low
AV:L/AC:L/Au:N/C:N/I:P/A:P - Weakness
- CWE-59
- Updated
- 2026-11-02
CVE List No score
alsa-utils 1.0.19 and later versions allows local users to overwrite arbitrary files via a symlink attack via the /usr/bin/alsa-info and /usr/bin/alsa-info.sh scripts.
- Record
CVE-2009-0035- Updated
- 2026-11-02
EUVDEUVD-2009-0046 No score
alsa-utils 1.0.19 and later versions allows local users to overwrite arbitrary files via a symlink attack via the /usr/bin/alsa-info and /usr/bin/alsa-info.sh scripts.
- Record
EUVD-2009-0046- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-37pq-pqpw-f637 No score
alsa-utils 1.0.19 and later versions allows local users to overwrite arbitrary files via a...
alsa-utils 1.0.19 and later versions allows local users to overwrite arbitrary files via a symlink attack via the /usr/bin/alsa-info and /usr/bin/alsa-info.sh scripts.
- Record
GHSA-37pq-pqpw-f637- Weakness
- CWE-59
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10544-1 No score
alsa-1.1.2-2.1 on GA media
These are all security issues fixed in the alsa-1.1.2-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10544-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
alsaopenSUSE:Tumbleweed |
before 1.1.2-2.1 | 1.1.2-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-0035 is a medium vulnerability (CVSS 5.5) in Alsa-project Alsa, published November 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in alsa 1.1.2-2.1.